Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.3
    • Fix Version/s: 1.2.4
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP professional, BEA Weblogic 8.1.6.0, Sun JDK 1.4.2_11-b06 OR BEA JRockit(R) Version R26.3.0-32_CR283061-63465-1.4.2_10-20060620-1811-win-ia32
    • Number of attachments :
      1

      Description

      The Xfire book example shows the stacktrace:
      Error 500--Internal Server Error
      java.lang.NoSuchMethodError: org.w3c.dom.Element.setTextContent(Ljava/lang/String;)V
      at org.codehaus.xfire.wsdl11.builder.WSDLBuilder.createElement(WSDLBuilder.java:281)
      at org.codehaus.xfire.wsdl11.builder.WSDLBuilder.createAbstractInterface(WSDLBuilder.java:221)
      at org.codehaus.xfire.wsdl11.builder.WSDLBuilder.write(WSDLBuilder.java:161)
      at org.codehaus.xfire.wsdl11.builder.WSDLBuilderAdapter.write(WSDLBuilderAdapter.java:40)
      at org.codehaus.xfire.DefaultXFire.generateWSDL(DefaultXFire.java:104)
      at org.codehaus.xfire.transport.http.XFireServletController.generateWSDL(XFireServletController.java:377)
      at org.codehaus.xfire.transport.http.XFireServletController.doService(XFireServletController.java:126)
      at org.codehaus.xfire.transport.http.XFireServlet.doGet(XFireServlet.java:107)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
      at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:1077)
      at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:465)
      at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:348)
      at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:7047)
      at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
      at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
      at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3902)
      at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2773)
      at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:224)
      at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:183)

      I have made the qname.jar adjustments as detailed in the XFire docs. I keep getting this error. I have attached the WAR being used as built by maven and modified to add qname.jar and weblogic.xml

        Activity

        Sohail Sikora added a comment -

        http://xfire.codehaus.org/Building

        did you even spend 10 minutes on the xfire website?

        Bob Bueckers added a comment -

        Yes I did spend some time on the site! I know exactly what you are referring to, just thought if someone else had gone through this process already, there was no need to re-invent the wheel... Make sense!

        Bob Bueckers added a comment -

        OK I went ahead and re-built with ANT and deployed the generated jar(xfire-core-1.2-SNAPSHOT.jar) with the distributed demo,. I no longer get the error mentioned above, but now receive another error when accessing(http://localhost:7001/xfire-book/services/BookService?wsdl), see below. Any ideas as to how I can resolve this one?

        Error 500--Internal Server Error

        java.lang.ClassCastException: weblogic.xml.jaxp.RegistrySAXTransformerFactory
        at javax.xml.transform.TransformerFactory.newInstance()Ljavax/xml/transform/TransformerFactory;(Unknown Source)
        at org.codehaus.xfire.wsdl11.builder.SchemaSerializer.writeXml(Lorg/w3c/dom/Node;Ljava/io/PrintWriter;)V(SchemaSerializer.java:46)
        at org.codehaus.xfire.wsdl11.builder.SchemaSerializer.marshall(Ljava/lang/Class;Ljavax/xml/namespace/QName;Ljavax/wsdl/extensions/ExtensibilityElement;Ljava/io/PrintWriter;Ljavax/wsdl/Definition;Ljavax/wsdl/extensions/ExtensionRegistry;)V(SchemaSerializer.java:35)
        at com.ibm.wsdl.xml.WSDLWriterImpl.printExtensibilityElements(Ljava/lang/Class;Ljava/util/List;Ljavax/wsdl/Definition;Ljava/io/PrintWriter;)V(Unknown Source)
        at com.ibm.wsdl.xml.WSDLWriterImpl.printTypes(Ljavax/wsdl/Types;Ljavax/wsdl/Definition;Ljava/io/PrintWriter;)V(Unknown Source)
        at com.ibm.wsdl.xml.WSDLWriterImpl.printDefinition(Ljavax/wsdl/Definition;Ljava/io/PrintWriter;)V(Unknown Source)
        at com.ibm.wsdl.xml.WSDLWriterImpl.writeWSDL(Ljavax/wsdl/Definition;Ljava/io/Writer;)V(Unknown Source)
        at com.ibm.wsdl.xml.WSDLWriterImpl.writeWSDL(Ljavax/wsdl/Definition;Ljava/io/OutputStream;)V(Unknown Source)
        at org.codehaus.xfire.wsdl11.builder.WSDLBuilder.write(Ljava/io/OutputStream;)V(WSDLBuilder.java:182)
        at org.codehaus.xfire.wsdl11.builder.WSDLBuilderAdapter.write(Ljava/io/OutputStream;)V(WSDLBuilderAdapter.java:40)
        at org.codehaus.xfire.DefaultXFire.generateWSDL(Ljava/lang/String;Ljava/io/OutputStream;)V(DefaultXFire.java:104)
        at org.codehaus.xfire.transport.http.XFireServletController.generateWSDL(Ljavax/servlet/http/HttpServletResponse;Ljava/lang/String;)V(XFireServletController.java:380)
        at org.codehaus.xfire.transport.http.XFireServletController.doService(Ljavax/servlet/http/HttpServletRequest;Ljavax/servlet/http/HttpServletResponse;)V(XFireServletController.java:125)
        at org.codehaus.xfire.transport.http.XFireServlet.doGet(Ljavax/servlet/http/HttpServletRequest;Ljavax/servlet/http/HttpServletResponse;)V(XFireServlet.java:107)
        at javax.servlet.http.HttpServlet.service(Ljavax/servlet/http/HttpServletRequest;Ljavax/servlet/http/HttpServletResponse;)V(HttpServlet.java:740)
        at javax.servlet.http.HttpServlet.service(Ljavax/servlet/ServletRequest;Ljavax/servlet/ServletResponse;)V(HttpServlet.java:853)
        at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run()Ljava/lang/Object;(ServletStubImpl.java:1072)
        at weblogic.servlet.internal.ServletStubImpl.invokeServlet(Ljavax/servlet/ServletRequest;Ljavax/servlet/ServletResponse;Lweblogic/servlet/internal/FilterChainImpl;)V(ServletStubImpl.java:465)
        at weblogic.servlet.internal.ServletStubImpl.invokeServlet(Ljavax/servlet/ServletRequest;Ljavax/servlet/ServletResponse;)V(ServletStubImpl.java:348)
        at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run()Ljava/lang/Object;(WebAppServletContext.java:6981)
        at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Lweblogic/security/subject/AbstractSubject;Ljava/security/PrivilegedAction;)Ljava/lang/Object;(AuthenticatedSubject.java:321)
        at weblogic.security.service.SecurityManager.runAs(Lweblogic/security/acl/internal/AuthenticatedSubject;Lweblogic/security/acl/internal/AuthenticatedSubject;Ljava/security/PrivilegedAction;)Ljava/lang/Object;(SecurityManager.java:121)
        at weblogic.servlet.internal.WebAppServletContext.invokeServlet(Lweblogic/servlet/internal/ServletRequestImpl;Lweblogic/servlet/internal/ServletResponseImpl;)V(WebAppServletContext.java:3892)
        at weblogic.servlet.internal.ServletRequestImpl.execute(Lweblogic/kernel/ExecuteThread;)V(ServletRequestImpl.java:2766)
        at weblogic.kernel.ExecuteThread.execute(Lweblogic/kernel/ExecuteRequest;)V(ExecuteThread.java:224)
        at weblogic.kernel.ExecuteThread.run()V(ExecuteThread.java:183)
        at java.lang.Thread.startThreadFromVM(Ljava/lang/Thread;)V(Unknown Source)

        Thanks again!

        Bob

        Sohail Sikora added a comment -

        http://xfire.codehaus.org/XFire+on+Weblogic+8.1

        try implementing the special instructions for WLS 8.1

        Dovie Chen added a comment -

        I tried on Oracle Weblogic 10.3 using xfire 1.2.6 according to the issues of "http://xfire.codehaus.org/XFire+on+Weblogic+8.1", but the linkageError remained.

        ]] Root cause of ServletException.
        java.lang.LinkageError: loader constraint violation in interface itable initialization: when resolving method "org.codehaus.xfire.wsdl11.builder.SchemaSerializer.marshall(Ljava/lang/Class;Ljavax/xml/namespace/QName;Ljavax/wsdl/extensions/ExtensibilityElement;Ljava/io/PrintWriter;Ljavax/wsdl/Definition;Ljavax/wsdl/extensions/ExtensionRegistry;)V" the class loader (instance of weblogic/utils/classloaders/ChangeAwareClassLoader) of the current class, org/codehaus/xfire/wsdl11/builder/SchemaSerializer, and the class loader (instance of java/net/URLClassLoader) for interface javax/wsdl/extensions/ExtensionSerializer have different Class objects for the type javax/xml/namespace/QName used in the signature
        at org.codehaus.xfire.wsdl11.builder.WSDLBuilder.<init>(WSDLBuilder.java:88)
        at org.codehaus.xfire.wsdl11.builder.DefaultWSDLBuilderFactory.createWSDLBuilder(DefaultWSDLBuilderFactory.java:25)
        at org.codehaus.xfire.wsdl11.builder.WSDLBuilderAdapter.write(WSDLBuilderAdapter.java:40)
        at org.codehaus.xfire.DefaultXFire.generateWSDL(DefaultXFire.java:104)
        at org.codehaus.xfire.transport.http.XFireServletController.generateWSDL(XFireServletController.java:380)
        Truncated. see log file for complete stacktrace
        >
        Can someone help me ?


          People

          • Assignee:
            Tomasz Sztelak
            Reporter:
            Sohail Sikora
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: