XFire
  1. XFire
  2. XFIRE-286

Error creating bean with name 'xfire.typeMappingRegistry'

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.0
    • Component/s: Spring
    • Labels:
      None
    • Environment:
    • Number of attachments :
      1

      Description

      Simple service that returns the input String fails. The log shows:
      [2/28/06 11:12:49:748 EST] 00000032 XFireServlet E Error initializing XFireServlet.
      [2/28/06 11:12:49:758 EST] 00000032 XFireServlet E TRAS0014I: The following exception was logged org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'xfire.typeMappingRegistry' defined in class path resource [org/codehaus/xfire/spring/xfire.xml]: Initialization of bean failed; nested exception is java.lang.VerifyError: (class: org/codehaus/xfire/aegis/type/basic/ObjectType, method: writeSchema signature: (Lorg/jdom/Element;)V) Incompatible argument to method
      java.lang.VerifyError: (class: org/codehaus/xfire/aegis/type/basic/ObjectType, method: writeSchema signature: (Lorg/jdom/Element;)V) Incompatible argument to method
      at org.codehaus.xfire.aegis.type.DefaultTypeMappingRegistry.createDefaultMappings(DefaultTypeMappingRegistry.java:294)

      A complete log is attached.

        Activity

        Per Hammer added a comment -

        Yep, seeing the same thing here.

        WebSphere Application Server 6.0.2.7
        Spring 1.2.6
        Xfire 1.0

        Works fine in JBoss 4.0.1, though, so it looks to be WAS6 related.

        Dan Diephouse added a comment -
        Mike Youngstrom added a comment -

        That fix worked for us. However I'm curious what the root cause of the issue is. We had 2 installations of websphere on 2 different machines. On the one we could deploy it with no problems and on the other we couldn't without the above fix. We haven't been able to determine what the difference was between the two.

        Dan Diephouse added a comment -

        The issue, from what I can tell, is that there is an old version of JDOM somewhere around. Does WebSphere use JDOM?

        Per Hammer added a comment -

        Yep, that's it.

        WebSphere/AppServer/lib contains a copy of JDOM Beta 7. Replaced it with JDOM 1.0 and everything started up just fine.

        Thanks for your help and quick response!

        =P

        Shahid Ahmed added a comment -

        Correct. It works fine when the JDOM package in WebSphere/AppServer/lib was replaced by JDOM 1.0.

        Your promptness in resolving the issue is impressive.

        Shahid

        Shahid Ahmed added a comment -

        The documentation could be updated with this platform specific issue:

        In WebSphere environment, check if the AppServer/lib contains the latest version of JDOM (at least 1.0). If not, replace the current JDOM package with JDOM 1.0 (or higher).

        Vladimir Aguirre Piedragil added a comment -

        Is correct!!!
        It's works!
        Thanks!!


          People

          • Assignee:
            Dan Diephouse
            Reporter:
            Shahid Ahmed
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: