Woodstox
  1. Woodstox
  2. WSTX-140

Woodstox defaults coalescing mode (IS_COALESCING) to true for readers; Stax specs mandate false

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Woodstox seems to default input factory settings for IS_COALESCING to true, which is both against stax specs (which define it should be define), and unintentional (it was supposed to be false). Interestingly none of the staxtest cases cover basic checks for settings (should be added); nonetheless this should be fixed in trunk for 4.0. For 3.x series, it probably should not be changed mostly because it does change observed behaviour for users who do not explicitly change IS_COALESCING setting from default.

        Activity

        Tatu Saloranta added a comment -

        Changed default to be Stax compliant (that it wasn't was an accident – I always thought coalescing mode was disabled), and added basic verificatio regression test into StaxTest.

        Tatu Saloranta added a comment -

        Included in 3.9.0 release.


          People

          • Assignee:
            Tatu Saloranta
            Reporter:
            Tatu Saloranta
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: