Maven Wagon
  1. Maven Wagon
  2. WAGON-83

mvn deploy causes NPE in ChecksumObserver.transferStarted

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-beta-2
    • Fix Version/s: 1.0-beta-3
    • Component/s: wagon-webdav
    • Labels:
      None
    • Number of attachments :
      1

      Description

      When doing a mvn deploy to an archiva repository, I get a NPE in ChecksumObserver.transferStarted. I can reproduce it every time on this project.
      The strange thing is that I never get it on other projects.

      Full debug log attached.

        Issue Links

          Activity

          Erik R. Jensen added a comment -

          I am also having this same problem. I see that the issue was opened originally in May of 2007. Has anyone had a chance to look at this issue further since then?

          Erik R. Jensen added a comment -

          I discovered my issue was a missing sha1 file on the server I was deploying too. I think a better error message would be useful. I'm also unsure what caused the checksum to fail to get deployed originally since I have been using wagon-webdav to deploy all along.

          Output from running "mvn -X"

          [DEBUG] SHA1 not found, trying MD5
          org.apache.maven.wagon.ResourceDoesNotExistException: File: http://srmmvn.provo.novell.com/archiva/repository/tools-snapshots/com/novell/zenworks/tools/web/novell-jasper/1.0.2.0-SNAPSHOT/novell-jasper-1.0.2.0-SNAPSHOT.pom.sha1 does not exist
          ...
          ...
          [ERROR] FATAL ERROR
          [INFO] ------------------------------------------------------------------------
          [INFO] null
          [INFO] ------------------------------------------------------------------------
          [DEBUG] Trace
          java.lang.NullPointerException
          at org.apache.maven.wagon.observers.ChecksumObserver.transferStarted(ChecksumObserver.java:65)

          Brett Porter made changes -
          Field Original Value New Value
          Workflow jira [ 71037 ] Maven New [ 88485 ]
          Brett Porter made changes -
          Fix Version/s 1.0-beta-3 [ 12544 ]
          Brett Porter added a comment -

          I was able to reproduce this by removing the .sha1 on beta-2, and in the latest code it no longer occurs

          Brett Porter made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Brett Porter [ brettporter ]
          Resolution Fixed [ 1 ]
          Brett Porter made changes -
          Link This issue is duplicated by MNG-3711 [ MNG-3711 ]

            People

            • Assignee:
              Brett Porter
              Reporter:
              Eric Barroca
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: