Maven Wagon
  1. Maven Wagon
  2. WAGON-400

Wagon 1.0 Fail to build from source with Java7

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      debian 7.0
    • Number of attachments :
      1

      Description

      I am build debian package of wagon 1.0, using Java7, but fail, for it can not pass some tests.

      Build log:

      -------------------------------------------------------
      T E S T S
      -------------------------------------------------------
      Running org.apache.maven.wagon.providers.http.HttpWagonTest
      Tests run: 42, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 4.926 sec
      Running org.apache.maven.wagon.providers.http.HttpsWagonTest
      Tests run: 42, Failures: 0, Errors: 19, Skipped: 0, Time elapsed: 4.984 sec <<< FAILURE!
      Running org.apache.maven.wagon.providers.http.HttpWagonTimeoutTest
      Tests run: 4, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 4.867 sec

      Results :

      Tests in error:
      testStreamingWagon(org.apache.maven.wagon.providers.http.HttpsWagonTest):
      testWagonGetIfNewerToStreamIsNewer(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonGetIfNewerToStreamIsOlder(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonGetIfNewerToStreamIsSame(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testFailedGetIfNewerToStream(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testFailedGetToStream(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagon(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonGetIfNewerIsNewer(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonGetIfNewerIsOlder(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonGetIfNewerIsSame(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonPutDirectory(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonPutDirectoryDeepDestination(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonPutDirectoryWhenDirectoryAlreadyExists(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonPutDirectoryForDot(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testFailedGet(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testFailedGetIfNewer(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonGetFileListWhenDirectoryDoesNotExist(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonResourceExists(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use
      testWagonResourceNotExists(org.apache.maven.wagon.providers.http.HttpsWagonTest): Address already in use

      Tests run: 88, Failures: 0, Errors: 19, Skipped: 0

      Full version of build log is in the attachment.

      More information is here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717280

        Activity

        Emmanuel Bourg added a comment -

        This is probably a duplicate of WAGON-335. Not sure it makes sense to backport the fix to wagon 1.x though.

        Olivier Lamy added a comment -

        Cannot reproduce with current version


          People

          • Assignee:
            Olivier Lamy
            Reporter:
            Shuxiong Ye
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: