The View.getValue() method should be renamed to View.getPath() since:
1. The term value is unnecessarily ambiguous and confusing and there are no use cases in which it is not used as a path.
2. It is more consistent with the ViewResolver interface
View.getValue() method remains as deprecated and will be removed in the future.