uDIG
  1. uDIG
  2. UDIG-965

Edit outlines + vertices drawn incorrectly

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: UDIG 1.1.RC3
    • Fix Version/s: UDIG 1.1.x, UDIG 1.2.M6
    • Component/s: tools and editing
    • Labels:
      None
    • Environment:
      WinXP SP2

      Description

      There is somthing very weird going on with the yellow selected lines and the vertices in editing mode - and it is not restricted to the hole cutting mode, obviously, but maybe it shows up there for me in the most prominent fashion.
      I opened bc_2m_lakes.shp and selected the geometry edit tool, as you see from the screenshot. Then I panned a lake to be in the center, selected it and zoomed in to the feature. After zooming in the yellow line and the vertices seem to be oddly displaced in a chaotic fashion. (See attachment) When I deselected the featue and selected it again, without zooming, the vertices were located at the right locations.

      When does this happen? Here are my best hypotheses:

      • If you select a feature that you did not select before for editing.
      • If you then pan and zoom to the feature
      • If you do several pan/zoom in actions quickly one after the other, while the drawing is not yet updated to the previous one.

      Sorry but even I cannot reproduce this EVERY time.

      1. patch.patch
        8 kB
        flavius burca
      1. EditLines&Vertices_bug.png
        10 kB

        Issue Links

          Activity

          Jesse Eichar added a comment -
          Unfortunately this cannot be fixed for 1.1.0 because it is too hard to reproduce and we are on a tight timeline
          Jody Garnett added a comment -
          bug brought forward to UDIG1.2.M4 visibility
          flavius burca added a comment -
          The problem is in net.refractions.udig.tools.edit.support.PrimitiveShape, method translate(AffineTransform). The shape is updated incorrectly.
          flavius burca added a comment -
          patch is attached
          Mauricio Pazos added a comment -
          We will doing a codereview, apply the patch and test it
          Mauricio Pazos added a comment -
          The bug was solved applying the patch provided by Favious Bruca.
          Commited in trunk revision 31351
          John Hudson added a comment -
          tested and verified on revision 31359.

            People

            • Assignee:
              John Hudson
              Reporter:
              Matthias Basler
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: