uDIG
  1. uDIG
  2. UDIG-735

uDIG cannot read shapefiles which extension file name are in captial letters

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: UDIG 1.0.5
    • Fix Version/s: UDIG 1.1.x, UDIG 1.2.M4
    • Component/s: application
    • Labels:
      None

      Description

      1. uDIG cannot read shapefiles which extension file name are in "capital letters". To open a shapefile the user has to be sure that the extension name of the files are not in capital letters (e.g. ARG_ADM1.shp NOT ARG_ADM1.SHP; ARG_ADM1.dbf NOT ARG_ADM1.DBF...... and so on.....)

        Issue Links

          Activity

          cedric added a comment -
          same problem for rasters
          Harry Bullen added a comment -
          This patch to the catalog.shp plugin partially fixes the issue. If you set the filter to *.* and then select a .SHP file it will load the layer if all the other file extensions are in uppercase.
          Jody Garnett added a comment -
          We need to retest as the shapefile handling code is different now in GeoTools 2.5.x - I do think we looked at this problem but it pays to check.
          Silvia Franceschi added a comment -
          It seems just a problem in the Import Wizard:
          1. if dragged and dropped everything works fine
          2. the import wizard does not show this shapes by default
          3. it works if you type the shapefile name in the Import Wizard

          Note: The shapefile will be visualized without the capital extension in the Catalog view.
          Silvia Franceschi added a comment -
          Unfortunately what I wrote regarding the fact that in the Catalog the shapefile is added without capital letters involve that if you close uDig and restart the shapefile is not found.
          Ugo Taddei added a comment -
          Cannot reproduce it (on Win XP). I do see something on the console (in a red font):
          ERROR 4: `C:\data\DEUTSCHLAND.SHP' not recognised as a supported file format.
          But the file gets read (and I believe I've seen this message with shapefiles not in upper case)
          Emily Gouge added a comment -
          I was able to reproduce this issue and fix it. You should now be able to load shapefiles with .SHP extension, close udig, and reopen it & have the files rendered correctly.

          Revision: 31218
          John Hudson added a comment -
          Verified on revision 31311.

            People

            • Assignee:
              John Hudson
              Reporter:
              Richard Gould
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: