uDIG
  1. uDIG
  2. UDIG-1902

ClassNotFoundException when using MigLayout classes from net.refractions.udig.libs

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.x
    • Fix Version/s: UDIG 1.3.2
    • Component/s: framework
    • Labels:
      None

      Description

      If a bundle uses MigLayout classes and the bundle automatically starts on application startup a ClassNotFoundException is thrown because of missing dependency to org.eclipse.swt (from net.refractions.udig.libs)

      Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Layout
      	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:513)
      	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:429)
      	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
      	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      

        Activity

        Andrea Antonello added a comment -
        I confirm this behaviour and also that by adding the dep, it works.
        Actually I though I had a JIRA opened already, but maybe I only wrote in list... or maybe I just lost myself...

        Thanks for bringing this back.

        Frank Gasdorf added a comment -
        see Commit (required bundle with version range for org.eclipse.swt) : https://github.com/uDig/udig-platform/commit/4a51fcf7f859917062a44a850c44dbadad918f73
        Frank Gasdorf added a comment -
        Andrea, I searched before I created this issue because I had similar thoughts of an already opened ticket, but haven't found any bug like this.
        Andrea Antonello added a comment -
        Great, I see the change si in. Good for me.

          People

          • Assignee:
            Frank Gasdorf
            Reporter:
            Frank Gasdorf
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: