uDIG
  1. uDIG
  2. UDIG-1848

Snapping tool option combo does not update when the preference is updated

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.x
    • Fix Version/s: UDIG 1.3.0
    • Component/s: tools and editing
    • Labels:
      None

      Description

      How to reproduce:
      Edit a feature and press Ctrl+Shift+S to change the snapping option.

        Activity

        Levi Putna added a comment - - edited
        So it looks like edit tools are using the putValue() method to set the preference. putValue sets the current value of the preference without sending a property change event. setValue() will do the same thing but fire the change event.

        I have run some test and cant seem to see any issue with using setValue over putValue. Paul can you test this using both the ToolOptionContribution, Command Shift S and the preference page to change the preference.

        Commit: https://github.com/uDig/udig-platform/commit/cc77acff9f63ae0a07fc761ac66de5313cceb76c
        Levi Putna added a comment -
        Moovida do you think you can also check this? I'm not sure if there are any other ways of changing the edit preferences.
        Levi Putna added a comment -
        Working, will close ticket when I get conformation from testers.
        Paul Pfeiffer added a comment -
        There appears to be something not happening with the combo in the options when grid is selected. Currently Ctrl Shift S makes the grid visible or not but the combo does not :(

          People

          • Assignee:
            Levi Putna
            Reporter:
            Paul Pfeiffer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: