Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.x
    • Fix Version/s: 2.x
    • Component/s: database
    • Labels:
      None
    • Environment:
      all

      Description

      It looks like the apache log4j plugin has been removed. If missing, I get exceptions:

      java.lang.NoClassDefFoundError: org/apache/log4j/Level
      at org.slf4j.LoggerFactory.getSingleton(LoggerFactory.java:189)

      We need to add back the plugin.

        Activity

        Jody Garnett added a comment -
        The slf4j project is an alternative to log4j that implements method compatibility. It is a bit of fun to mix slf4j with log4j in the same project.

        How was the tied in before? As as a plugin or as part of libs?
        Andrea Antonello added a comment -
        I think slf4j supplies the interfaces and you can use log4j under the hood through slf4j.

        I am not able to check from here. But I think I remember that older versions of uDig have an apache.log4j plugin in the plugins folder.
        Jody Garnett added a comment -
        Can you fill in some details on how you get the above error? If I cannot reproduce the problem I cannot work on it...
        Andrea Antonello added a comment -
        Tested and by readdign apache log4j everything works fine again. Closing the issue.
        Andrea Antonello added a comment -
        Jody fixed that by re-addign the apache log4j plugin. Working no in 1.3.x stream

          People

          • Assignee:
            Jody Garnett
            Reporter:
            Andrea Antonello
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: