uDIG
  1. uDIG
  2. UDIG-1723

Error appears for each layer

    Details

    • Type: Bug Bug
    • Status: Open Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: UDIG 1.2.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      WinXP, uDig 1.2.0

      Description

      "[Fatal Error] :1:39: Premature end of file." appears in Eclipse console for each layer that is displayed on map.

      This is 99% connected with

      <content iD="net.refractions.udig.mapgraphic.style.font" memento="<?xml version="1.0" encoding="UTF-8"?> &#xA ....

      entries from .umap file as
      <?xml version="1.0" encoding="UTF-8"?>
      is (after being retranslated to pure text ) exactly 39 chars long

        Activity

        Hide
        Lukasz Stawicki added a comment -
        Debugged it finally.
        Thread [Worker-3] (Suspended (exception SAXParseException))
        SAXParser(AbstractSAXParser).parse(InputSource) line: not available
        ShowViewInterceptor$ViewStyleContent.readFilter(String) line: 315
        ShowViewInterceptor$ViewStyleContent.load(IMemento) line: 258
        StyleBlackboardImpl.getObject(StyleEntry) line: 249
        StyleBlackboardImpl.get(String) line: 165
        ShowViewInterceptor.run(ILayer, FeatureSource<SimpleFeatureType,SimpleFeature>, Class<FeatureSource<SimpleFeatureType,SimpleFeature>>) line: 123
        ShowViewInterceptor.run(ILayer, Object, Class) line: 1
        LayerResource$Wrapper<T>.run(ILayer, T, Class<? super T>) line: 399
        LayerResource.runInterceptors(Class<T>, T, List<Wrapper<T>>) line: 177
        LayerResource.processPostResourceInterceptors(T, Class<T>) line: 272
        LayerResource.resolve(Class<T>, IProgressMonitor) line: 145
        LayerImpl.getResource(Class<E>, IProgressMonitor) line: 758
        LayerImpl.getSchema() line: 1600
        LayerGeneratedGlyphDecorator.generateStyledIcon(ILayer, Rule) line: 457
        LayerGeneratedGlyphDecorator.generateStyledIcon(Layer) line: 420
        LayerGeneratedGlyphDecorator.generateIcon(Layer) line: 389
        LayerGeneratedGlyphDecorator$2.refreshIcon(Layer) line: 183
        LayerGeneratedGlyphDecorator$2.run(IProgressMonitor) line: 156
        Worker.run() line: 54

        the entry that is being tried to read is

        <content iD="net.refractions.udig.project.view" memento="&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?>&#xD;&#xA;&lt;styleEntry TYPENAME=&quot;Feature&quot;>%3C%3Fxml+version%3D%221.0%22+encoding%3D%22UTF-8%22%3F%3E&lt;/styleEntry>"/>

        And it happens for each layer.

        Show
        Lukasz Stawicki added a comment - Debugged it finally. Thread [Worker-3] (Suspended (exception SAXParseException)) SAXParser(AbstractSAXParser).parse(InputSource) line: not available ShowViewInterceptor$ViewStyleContent.readFilter(String) line: 315 ShowViewInterceptor$ViewStyleContent.load(IMemento) line: 258 StyleBlackboardImpl.getObject(StyleEntry) line: 249 StyleBlackboardImpl.get(String) line: 165 ShowViewInterceptor.run(ILayer, FeatureSource<SimpleFeatureType,SimpleFeature>, Class<FeatureSource<SimpleFeatureType,SimpleFeature>>) line: 123 ShowViewInterceptor.run(ILayer, Object, Class) line: 1 LayerResource$Wrapper<T>.run(ILayer, T, Class<? super T>) line: 399 LayerResource.runInterceptors(Class<T>, T, List<Wrapper<T>>) line: 177 LayerResource.processPostResourceInterceptors(T, Class<T>) line: 272 LayerResource.resolve(Class<T>, IProgressMonitor) line: 145 LayerImpl.getResource(Class<E>, IProgressMonitor) line: 758 LayerImpl.getSchema() line: 1600 LayerGeneratedGlyphDecorator.generateStyledIcon(ILayer, Rule) line: 457 LayerGeneratedGlyphDecorator.generateStyledIcon(Layer) line: 420 LayerGeneratedGlyphDecorator.generateIcon(Layer) line: 389 LayerGeneratedGlyphDecorator$2.refreshIcon(Layer) line: 183 LayerGeneratedGlyphDecorator$2.run(IProgressMonitor) line: 156 Worker.run() line: 54 the entry that is being tried to read is <content iD="net.refractions.udig.project.view" memento="&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?>&#xD;&#xA;&lt;styleEntry TYPENAME=&quot;Feature&quot;>%3C%3Fxml+version%3D%221.0%22+encoding%3D%22UTF-8%22%3F%3E&lt;/styleEntry>"/> And it happens for each layer.
        Hide
        Andrea Antonello added a comment -
        Thank you for the good catch. I will loook into it. I only have to understand if this is going into the git or svn repo.
        Show
        Andrea Antonello added a comment - Thank you for the good catch. I will loook into it. I only have to understand if this is going into the git or svn repo.
        Hide
        Andrea Antonello added a comment -
        I finally found time to look into this but can't reproduce it any more. I am on linux 64 bit. Can you supply any additional info or even a patch for me to apply blind to then test it?
        Show
        Andrea Antonello added a comment - I finally found time to look into this but can't reproduce it any more. I am on linux 64 bit. Can you supply any additional info or even a patch for me to apply blind to then test it?

          People

          • Assignee:
            Andrea Antonello
            Reporter:
            Lukasz Stawicki
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: