Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: UDIG 1.1.0
    • Fix Version/s: UDIG 1.2.RC3
    • Component/s: application
    • Labels:
      None
    • Environment:
      gMLDZoj

      Description

      gMLDZoj

        Activity

        Mauricio Pazos made changes -
        Field Original Value New Value
        Assignee Mauricio Pazos [ mauro ]
        Mauricio Pazos added a comment - - edited
        Dear Andreas, thanks a lot for your report.
        The commented fail usually is solved executing the "uDig -clean command".
        I see you are using a very old release, it is "rc" (Release Candidate), this kind of release is done for testing purpose. So, I suggest you to update for getting a stable release. Right now, in the "udig update site" is available 1.1.4 (alternatively it is available in the downloads page http://www.axios.es/ ).

        Let me now if you have success.

        best regards
          
        Mauricio Pazos made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Andreas Schild added a comment -
        Dear Mauricio,

        Thanks a lot for Your answer!

        Now I've done the following:

        i) I have installed uDig 1.1.1. from scratch (after uninstalling it)
        ii) Installed the axios extension 1.1.4. via the "Help" menue > "Find and install"
        iii) start uDig with "udig -clean"

        The issue remains unaffected when using the "Merge Tool" against a POSTGIS POLYGON FEATURE.
        This means when i use the "Merge Tool" by selecting 2 adjacent polygons the "Merge Tool Window" does not appear and the 2 adjacent polygons are not merged.

        However if I use the release canditate 1.1.0.rc8 (as mentioned above) the "Merge Tool" works fine against the POSTGIS POLYGON FEATURE.

        I also tried the "Merge Tool" against a POLYGON SHAPEFILE and everything works fine!!

        Below I've included the Definition of the PostGIS layer.

        Thanks again a lot for Your dedication

        Best regards,

        Andreas

        *******************************************************************************************************

        CREATE ROLE comphy LOGIN PASSWORD '*******' NOINHERIT VALID UNTIL 'infinity';
        CREATE SCHEMA comphy AUTHORIZATION comphy;

        GRANT ALL ON SCHEMA comphy TO comphy;
        GRANT SELECT ON public.geometry_columns to comphy;
        GRANT SELECT ON public.spatial_ref_sys to comphy;

        CREATE TABLE comphy.abfl_klasse_poly
        (
          ogc_fid serial NOT NULL,
          abfl_klasse INTEGER
         );

        SELECT AddGeometryColumn('comphy', 'abfl_klasse_poly', 'wkb_geometry', 31287, 'POLYGON', 2);

        GRANT INSERT, SELECT, UPDATE, DELETE ON comphy.rauhigk_klasse_poly TO comphy;

        GRANT ALL ON TABLE comphy.abfl_klasse_poly_ogc_fid_seq TO comphy;

        ALTER TABLE comphy.abfl_klasse_poly ADD CONSTRAINT abfl_klasse_poly_pk PRIMARY KEY (ogc_fid);
        CREATE INDEX abfl_klasse_poly_gist1 ON comphy.abfl_klasse_poly USING GIST (wkb_geometry);
        made changes -
        Status In Progress [ 3 ] Analysis [ 10002 ]
        Judith Elaine Bush added a comment -
        I'm commenting here but i don't know if this should be a new bug/request or just noobie help: I'd like to install the axios toolkit using

        Find & Install | (*) search for new features | ...

        but my "sites to include in search" list is empty and it's not clear where the update site is. I am running Version: 1.2-M6.

        Any pointers to what the URL is for the update site?

        Thanks!
        Judith Elaine Bush added a comment -
        I actually found the documentation, but when i try http://udig.refractions.net/update I get the error

        {quote}
        Network connection problems encountered during search.
          Unable to access "http://udig.refractions.net/update".
            Error parsing site stream. [White spaces are required between publicId and systemId.]
            White spaces are required between publicId and systemId.
            Error parsing site stream. [White spaces are required between publicId and systemId.]
            White spaces are required between publicId and systemId.
        {quote}
        Mauricio Pazos added a comment -
        Hi, the last release is not available for uDig 1.2. We are scheduling this task in
        "1.3.0-m1 Porting to udig 1.2 milestone."

        For details, have a look at
        http://udig.refractions.net/confluence/display/COM/Spatial+Operations+and+Editing+Tools

        "1.3.x Development branch for uDig 1.2.x"

        I think we will build a release this week.

        About, the reported bug in this issue we are planned the task in
         
        "1.3.0-m2 Paralellels and Merge bug fixing"

        cheers


        made changes -
        Component/s tools and editing [ 11253 ]
        Component/s community axios [ 12703 ]
        Status Analysis [ 10002 ] Open [ 1 ]
        Environment XP, against PostgreSQL/PostGIS gMLDZoj
        Description Dear Developers, dear List!

        We are editing with uDig and the axios edittool plugin on Windows XP PC's against a PostgreSQL/PostGIS Database running on a Linux Host.

        With the axios edittoolsrc08 we were able to split and merge polygon features (a functionality which we appreciate very much). Since edittolsrc09 (including the recent version of axios) the merge tool does not work anymore - which means that it does'nt do anything.

        Until now the problem is not very critical to us, because by copying the es.axios.udig.extensions_1.1.0.rc8 folder and the 3 jar files (es.axios.udig.ui.commons_1.1.0.rc8.jar, es.axios.udig.ui.editingtools_1.1.0.rc8.jar, es.axios.udig.ui.spatialoperations_1.1.0.rc8.jar) into the "...\uDig\1.1.1\eclipse\plugins\" folder everything works fine.

        Thanks a lot and have a good day!

        Nice Greetings from vienna,
        <andi>
        gMLDZoj
        Jody Garnett made changes -
        Fix Version/s UDIG 1.2.0 [ 16264 ]
        Mauricio Pazos made changes -
        Status Open [ 1 ] Analysis [ 10002 ]
        Mauricio Pazos made changes -
        Status Analysis [ 10002 ] Resolved [ 5 ]
        Fix Version/s UDIG 1.2.RC3 [ 16441 ]
        Fix Version/s UDIG 1.2.0 [ 16264 ]
        Resolution Fixed [ 1 ]
        Jody Garnett made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Mauricio Pazos
            Reporter:
            Andreas Schild
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: