Details

      Description

      WMSC kind of goes crazy when outside the bounds of the current CRS - the use of GDA64 in the above map produces some pretty interesting results. These are all fixed up by the time you zoom into Australia which is where the CRS valid region is.

      1. tilemiss.jpg
        118 kB
      2. tilemiss2.jpg
        97 kB

        Activity

        Jody Garnett made changes -
        Field Original Value New Value
        Attachment tilemiss2.jpg [ 42194 ]
        Attachment tilemiss.jpg [ 42193 ]
        Jody Garnett added a comment -
        first screen taken with memory cache; second screen taken with file cache (going to C:\temp)
        Emily Gouge added a comment -
        If you change the map projection back to some world projection (4326) you'll see a more normal tile distribution. I believe this occurs because the map projection not making sense for areas far away from Australia.
        Jody Garnett added a comment -
        Thanks emily; I feel stupid now :-) I have renamed this issue ....

        To fix this we may be able to "clip" the region for which the WMSC bothers to fetch tiles to that provided by the CoordianteReferenceSystem? I think I want to make a map graphic which displays the valid CRS area for the map.
        Jody Garnett made changes -
        Summary Duel Core is Dueling Cores for WMSC WMSC in GDA64
        Description Contacting the bluemarble layer on sigma works fine; unless I am on a duel core machine; it looks from the second screen snapshot as if we are getting a race condition (and tiles are being recorded in the wrong location). WMSC kind of goes crazy when outside the bounds of the current CRS - the use of GDA64 in the above map produces some pretty interesting results. These are all fixed up by the time you zoom into Australia which is where the CRS valid region is.
        Jody Garnett made changes -
        Fix Version/s UDIG 1.2.M5 [ 15119 ]
        Fix Version/s UDIG 1.2.M6 [ 15474 ]
        Jody Garnett made changes -
        Fix Version/s UDIG 1.2.M7 [ 15476 ]
        Fix Version/s UDIG 1.2.M6 [ 15474 ]
        Jody Garnett made changes -
        Fix Version/s UDIG 1.2.M7 [ 15476 ]
        Fix Version/s UDIG 1.2.M9 [ 16115 ]
        Jody Garnett made changes -
        Fix Version/s UDIG 1.2.M9 [ 16115 ]
        Fix Version/s UDIG 1.2.RC [ 16163 ]
        Jody Garnett made changes -
        Fix Version/s UDIG 1.2.0 [ 16264 ]
        Fix Version/s UDIG 1.2.RC [ 16163 ]
        Jody Garnett added a comment -
        This won't be fixed; the map was simply zoomed too far outside the valid area for the crs.
        Jody Garnett made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Not A Bug [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Jody Garnett
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: