uDIG
  1. uDIG
  2. UDIG-1506

Pan and Zoom causes vertexes to be slightly displaced when editing

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: UDIG 1.2.M4
    • Fix Version/s: UDIG 1.2.RC2
    • Component/s: tools and editing
    • Labels:
      None

      Description

      When editing the vertexes of a polygon, after a number of zooming and panning operations, the vertexes appear slightly displaced from the original feature.

        Issue Links

          Activity

          Jody Garnett added a comment -
          Have a look at the diagrams on this page: http://udig.refractions.net/confluence/display/DEV/07+Edit+Tools

          The origional JTS geometry is processed into a data structure for display; this step (simplification?) is dependent on the zoom level; one vertex on screen can represent several JTS coordinates in the origional geometry). This step should be done again if the user zooms in or zooms out; but currently it is only done once.
          Mauricio Pazos added a comment -
          We cannot reproduce this bug in 1.2 -trunk and 1.2.0-RC1. We think it was solved with the patch applied in http://jira.codehaus.org/browse/UDIG-965
           

            People

            • Assignee:
              Mauricio Pazos
              Reporter:
              flavius burca
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: