uDIG
  1. uDIG
  2. UDIG-1500

Problem with style when quote encountered

    Details

    • Type: Bug Bug
    • Status: Open Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: UDIG 1.1.1
    • Fix Version/s: UDIG 1.4.1
    • Component/s: application
    • Labels:
      None

      Description

      Whenever there is a quote ( '\'') in the value of an attribute, udig fails when attempting to produce a style based on this attribute (unfortunately, the quote is often used in french : " rue de l'arrivée " instead of " rue de la arrivée " when you uses adresses ).

      1. test.sql
        28 kB
        Laurent Pierre

        Activity

        Hide
        Jody Garnett added a comment -
        Sorry Pierre you are going to need to work a bit more before I can reproduce this bug. Are you using the quote in an attribute name? (oh wait apparently not) - is a label in a text symbolizer? I think I am going to assume a text symbolizer?

        Can I ask you to attach an example shapefile and style that can be used to reproduce the problem? even a single feature will be fine.
        Show
        Jody Garnett added a comment - Sorry Pierre you are going to need to work a bit more before I can reproduce this bug. Are you using the quote in an attribute name? (oh wait apparently not) - is a label in a text symbolizer? I think I am going to assume a text symbolizer? Can I ask you to attach an example shapefile and style that can be used to reproduce the problem? even a single feature will be fine.
        Hide
        Laurent Pierre added a comment -
        Hi Jody,

        The bug appears only when UDIG uses a PostGIS connection. I join a dump of a table with a value containing '\'' in the 'nom_region' column. When you try to define a style using this attribute UDIG shows an error.

        Laurent

        PS : by the way, when you have an attribute with boolean values, UDIG fails to define a style too.
        Show
        Laurent Pierre added a comment - Hi Jody, The bug appears only when UDIG uses a PostGIS connection. I join a dump of a table with a value containing '\'' in the 'nom_region' column. When you try to define a style using this attribute UDIG shows an error. Laurent PS : by the way, when you have an attribute with boolean values, UDIG fails to define a style too.

          People

          • Assignee:
            Unassigned
            Reporter:
            Laurent Pierre
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: