Details

    • Type: Bug Bug
    • Status: Reopened Reopened
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: UDIG 1.1.x, UDIG 1.2.M1
    • Fix Version/s: UDIG 1.1.1, UDIG 1.2.M4
    • Component/s: application
    • Labels:
      None
    • Environment:
      Windows XP; JRE6; using a local tilecache with a tileset called topp:states(EPSG:4326:image/png)

      Description

      When you create a map; close udig and reopen it you sometimes get "Unable to Open Map" errors.
      One reason for this error is ":" in the map name (as these are not valid in Windows file names).

      I have fixed this for ":" but we might want to get a list of all the invalid characters to ensure it doesn't happen for other characters as well. Does anyone have a good reference?

      I also suspect there are other reasons for the "Unable to Load Map" as well but I haven't tracked them down.

        Activity

        Jody Garnett made changes -
        Field Original Value New Value
        Component/s open and save [ 11074 ]
        Component/s application [ 11551 ]
        Andrea Antonello made changes -
        Fix Version/s UDIG 1.2.M3 [ 14979 ]
        Fix Version/s UDIG 1.1.2 [ 14910 ]
        Jody Garnett made changes -
        Assignee Jesse Eichar [ jeichar@refractions.net ]
        Hide
        Silvia Franceschi added a comment -
        Still present in uDig1.1 and uDig1.2-M3.
        It happens for the maps not opened of the same project, or of different projects as the opened map when restarting uDig.
        Show
        Silvia Franceschi added a comment - Still present in uDig1.1 and uDig1.2-M3. It happens for the maps not opened of the same project, or of different projects as the opened map when restarting uDig.
        Silvia Franceschi made changes -
        Assignee Jack Van Thelsting [ jacktester ]
        Silvia Franceschi made changes -
        Priority Minor [ 4 ] Critical [ 2 ]
        Fix Version/s UDIG 1.1.2 [ 14910 ]
        Hide
        Andrea Antonello added a comment -
        this seems to work on 1.2 derivates, but still a problem with 1.1. Removing the M3 fix version
        Show
        Andrea Antonello added a comment - this seems to work on 1.2 derivates, but still a problem with 1.1. Removing the M3 fix version
        Andrea Antonello made changes -
        Fix Version/s UDIG 1.1.2 [ 14910 ]
        Affects Version/s UDIG 1.1.x [ 15093 ]
        Assignee Jack Van Thelsting [ jacktester ] Andrea Antonello [ moovida ]
        Fix Version/s UDIG 1.2.M3 [ 14979 ]
        Ben Walding made changes -
        Workflow jira [ 102012 ] udig [ 107787 ]
        Hide
        Andrea Antonello added a comment -
        Ok, this was not a udig issue, but a JGrass one.
        In JGrass in the stop of one of the plugins, some tasks were executed before udig shutdown. That was blocking the writing of the map file in the workspace.
        Closed for me.
        Show
        Andrea Antonello added a comment - Ok, this was not a udig issue, but a JGrass one. In JGrass in the stop of one of the plugins, some tasks were executed before udig shutdown. That was blocking the writing of the map file in the workspace. Closed for me.
        Andrea Antonello made changes -
        Fix Version/s UDIG 1.2.M4 [ 15071 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s UDIG 1.1.1 [ 11974 ]
        Fix Version/s UDIG 1.1.2 [ 14910 ]
        Resolution Fixed [ 1 ]
        Jody Garnett made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hide
        Silvia Franceschi added a comment -
        Unable to load map always happens to me with uDig1.2 in Linux64 when I delete a Map previously created. So just:
        1. open uDig and create 3 Maps, close all but one
        2. close uDig
        3. reopen uDig and delete one of the closed Maps
        4. create a new Map
        5. close uDig
        6. restart uDig -> only the opened Map is loaded correctly for the first two Maps you have an Unable to Load Map in the Projects View
        Show
        Silvia Franceschi added a comment - Unable to load map always happens to me with uDig1.2 in Linux64 when I delete a Map previously created. So just: 1. open uDig and create 3 Maps, close all but one 2. close uDig 3. reopen uDig and delete one of the closed Maps 4. create a new Map 5. close uDig 6. restart uDig -> only the opened Map is loaded correctly for the first two Maps you have an Unable to Load Map in the Projects View
        Silvia Franceschi made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]

          People

          • Assignee:
            Andrea Antonello
            Reporter:
            Emily Gouge
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: