uDIG
  1. uDIG
  2. UDIG-1436

Cannot edit a single polygon

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: UDIG 1.1-SC1
    • Fix Version/s: UDIG 1.2.M6
    • Component/s: tools and editing
    • Labels:
      None
    • Environment:
      XP, JRE 1.6.0_06-b02, 3.3.2.R33x_v20080105, Release 1.1-SC3

      Description

      Create a polygon dataset using uDig 1.1-SC3.
      Move the vertexes of the polygon or add vertexes.
      Try to double-click -> nothing happens! (even though the new shape of the poly should be now be realised)
      Commit the changes or select another tool -> the polygon reverts back to it's original state and changes are lost!
      This behaviour doesn't occur every time a polygon is drawn and edited. If you don't see it happen the first time, draw another polygon and try again.

      If Editing Blackboard is used and several polygons are selected, then editing works just fine..

      No messages appear in the error log when this behaviour occurs.

      1. screenshot-1.jpg
        31 kB
      2. screenshot-2.jpg
        29 kB
      3. screenshot-3.jpg
        27 kB

        Activity

        Jani Kylmäaho added a comment -
        Here is the drawn polygon..
        Jani Kylmäaho added a comment -
        ..here is the edited polygon..
        Jani Kylmäaho added a comment -
        ..and here is the polygon after pressing Commit (back to it's original shape).
        Jesse Eichar added a comment -
        I have been investigating this exact issue. It is a tough one because (at least for me) it works much of the time but occasionally will just up and die. Some times switching tools is enough to get it to reset. some times a commit or rollback is needed. I have some ideas and I hope to get this fix in for 1.1.1 but that is coming out quite soon so it may be 1.1.2
        Konrad Garus added a comment -
        The issue is 100% reproducible for me in 1.1.1. The multiselect workaround sometimes (but not always) works. Is there something I can do to help with investigation? Is there a known workaround that always works?

          People

          • Assignee:
            Unassigned
            Reporter:
            Jani Kylmäaho
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: