uDIG
  1. uDIG
  2. UDIG-1429

library conflict during startup

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: UDIG 1.1-SC1
    • Fix Version/s: UDIG 1.2.M6
    • Component/s: framework
    • Labels:
      None
    • Environment:
      Linux Fedora Core 9 - AMD x2 in 32bit mode

      Description

      I get a segfault on startup. gdb shows the segfault occurs in /usr/lib/xulrunner-1.9/lubxul.so

      removing the library enables UDIG to startup and run correctly.

      RC14 did not exhibit this problem.

      So there is a library or symbol conflict with xulrunner-1.9/libxul.so and some part of UDIG. I did not setup a debug build to find out which.
      libxul.so is part of the xulrunner rpm package.

        Activity

        carl anderson added a comment -
        issue is cleared in UDIG 1.1-SC2
        carl anderson added a comment -
        Take that back now, occurs during query of WMS layers.

        Looks like this is a jvm issue...
        a similar issue is (http://saloon.javaranch.com/cgi-bin/ubb/ultimatebb.cgi?ubb=get_topic&f=12&t=005855)

        Tried booting in single CPU mode, no go.

        Tried updating to jre 1.6.0_07, no go.

        still looking.

        carl anderson added a comment -
        This is a bug in Eclipse 3.3 not UDIG

        https://bugs.eclipse.org/bugs/show_bug.cgi?id=236724

        appears to be fixed in Eclipse 3.4.1

        Still without employing a workaround

        https://bugs.eclipse.org/bugs/show_bug.cgi?id=236724#c22

        Linux Fedora users will broken. A note in the SC2 release notes would be helpful.
        Jody Garnett added a comment -
        Starting this way is a workaround:
        - /usr/local/src/udig/udig -configuration ~/.udig -vmargs -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/bin/xulrunner

        Documentation of the workaround added to http://udig.refractions.net/confluence/display/EN/Running+uDig

        Moving to Eclipse 3.4 would also address this issue.
        Andrea Antonello added a comment -
        HAs this been solved with 3.4.1? To be checked at the code sprint.
        Silvia Franceschi added a comment -
        Don't understand the bug... Can not try to reproduce it.

          People

          • Assignee:
            Unassigned
            Reporter:
            carl anderson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: