uDIG
  1. uDIG
  2. UDIG-1231

Cannot install as shared application on gnu/linux

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: UDIG 1.1.RC9
    • Fix Version/s: UDIG 1.2.M6
    • Labels:
      None
    • Environment:
      gnu/linux

      Description

      uDig cannot be installed on gnu/linux as a shared application.

      If user alice installs uDig under /foo, even if Alice grants permissive settings on the application with
      chmod -R a+w /foo
      when user Joni attempts to run uDig with
      /foo/udig/udig
      then uDig launches and the JVM right away reports the error reported by Prof. Keitt in his message to the mailing list:

      ***************************************************************************
      I tried RC9 today and two things I noticed:

      1) If I download and unzip everything into /opt/udig as root and then
      run uDig as an ordinary user, it dies with JVM error code=13.
      Apparently uDig needs write access to its installation directory in
      order to work. That makes no sense in a Linux environment where app
      directories are generally not touched by users.

      *****************************************************************************

      Note also that this category of bugs could be altered from 'installer' to 'installation' issues.

      --adrian

        Activity

        Jesse Eichar added a comment -
        This is not a bug. You have to run uDig with the -configuration option to run it as a shared program. For example:

        udig -configuration ~/.udig

        These are standard eclipse configuration options. I will change the bug to be

        "Add a page for command line options for uDig"

        Andrea Antonello added a comment -
        Please define if this is closed or not or been redirected into a new bug and can be marked as solved.

          People

          • Assignee:
            Unassigned
            Reporter:
            Adrian Custer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: