Maven Surefire
  1. Maven Surefire
  2. SUREFIRE-901

Failsafe verify fails if no failsafe-summary.xml can be found

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.12.2
    • Fix Version/s: 2.12.3
    • Component/s: Maven Failsafe Plugin
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      I just upgraded to 2.12.2 and failsafe verify appears to be failing if failsafe didn't run any tests. It appears to be looking for a failsafe-summary.xml file which wasn't created when failsafe ran no tests.

      Even though the build log says "Recording test results[INFO] Failsafe report directory: /home/bldmgr/Hudson/workspace/stack-tcat/api/target/failsafe-reports" no failsafe-reports directory was ever created.

      [INFO] --- maven-failsafe-plugin:2.12.2:integration-test (integration-tests) @ stack-tcat-api ---
      [JENKINS] Recording test results[INFO] Failsafe report directory: /home/bldmgr/Hudson/workspace/stack-tcat/api/target/failsafe-reports
      
      [INFO] 
      [INFO] --- maven-failsafe-plugin:2.12.2:verify (verify-integration-tests) @ stack-tcat-api ---
      [JENKINS] Archiving disabled - not archiving /home/bldmgr/Hudson/workspace/stack-tcat/api/pom.xml
      [JENKINS] Archiving disabled - not archiving /home/bldmgr/Hudson/workspace/stack-tcat/api/target/stack-tcat-api-1.1.15-SNAPSHOT.jar
      [JENKINS] Archiving disabled - not archiving /home/bldmgr/Hudson/workspace/stack-tcat/api/target/stack-tcat-api-1.1.15-SNAPSHOT-sources.jar
      [JENKINS] Archiving disabled - not archiving /home/bldmgr/Hudson/workspace/stack-tcat/api/target/stack-tcat-api-1.1.15-SNAPSHOT-test-sources.jar
      [JENKINS] Archiving disabled - not archiving /home/bldmgr/Hudson/workspace/stack-tcat/api/target/stack-tcat-api-1.1.15-SNAPSHOT-javadoc.jar
      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO] 
      [INFO] Stack TCat Parent ................................. SUCCESS [19.813s]
      [INFO] Stack Tcat API .................................... FAILURE [32.484s]
      [INFO] Stack Tcat Deploy Plugin .......................... SKIPPED
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 54.724s
      [INFO] Finished at: Fri Aug 10 11:13:32 MDT 2012
      [WARNING] The requested profile "ics-profile" could not be activated because it does not exist.
      [WARNING] The requested profile "continuous" could not be activated because it does not exist.
      [INFO] Final Memory: 27M/172M
      [INFO] ------------------------------------------------------------------------
      mavenExecutionResult exceptions not empty
      message : Failed to execute goal org.apache.maven.plugins:maven-failsafe-plugin:2.12.2:verify (verify-integration-tests) on project stack-tcat-api: /home/bldmgr/Hudson/workspace/stack-tcat/api/target/failsafe-reports/failsafe-summary.xml (No such file or directory)
      cause : /home/bldmgr/Hudson/workspace/stack-tcat/api/target/failsafe-reports/failsafe-summary.xml (No such file or directory)
      Stack trace : 
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-failsafe-plugin:2.12.2:verify (verify-integration-tests) on project stack-tcat-api: /home/bldmgr/Hudson/workspace/stack-tcat/api/target/failsafe-reports/failsafe-summary.xml (No such file or directory)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      	at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:79)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
      	at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:158)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:104)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:70)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:287)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:662)
      Caused by: org.apache.maven.plugin.MojoExecutionException: /home/bldmgr/Hudson/workspace/stack-tcat/api/target/failsafe-reports/failsafe-summary.xml (No such file or directory)
      	at org.apache.maven.plugin.failsafe.VerifyMojo.execute(VerifyMojo.java:195)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
      	... 27 more
      Caused by: java.io.FileNotFoundException: /home/bldmgr/Hudson/workspace/stack-tcat/api/target/failsafe-reports/failsafe-summary.xml (No such file or directory)
      	at java.io.FileInputStream.open(Native Method)
      	at java.io.FileInputStream.<init>(FileInputStream.java:106)
      	at org.apache.maven.plugin.failsafe.VerifyMojo.readSummary(VerifyMojo.java:214)
      	at org.apache.maven.plugin.failsafe.VerifyMojo.execute(VerifyMojo.java:182)
      	... 29 more
      

        Activity

        Mike Youngstrom added a comment -

        This appears to be a regression in 2.12.2 only as 2.12.1 seems to work fine.

        Kristian Rosenvold added a comment -

        Fixed with IT in r1371975


          People

          • Assignee:
            Kristian Rosenvold
            Reporter:
            Mike Youngstrom
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: