Maven Surefire
  1. Maven Surefire
  2. SUREFIRE-837

Surefire 2.12 fails after first module

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.12
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Maven 3.0.4, surefire 2.12, JUnit 4.10, JDK1.6_30, WinXP
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      We have a big issue with surefire 2.12 (using default configuration, which means forkMode=once): the Junit tests of the first module pass perfectly, then we have a "Z,0,BYE!" in the log and the surefire plugin fails with:

      The forked VM terminated without saying properly goodbye. VM crash or System.exit called ?
              at org.apache.maven.plugin.surefire.booterclient.output.ForkClient.close(ForkClient.java:244)
      

      It seems related to the following code, taken from maven/surefire/trunk/surefire-booter/src/main/java/org/apache/maven/surefire/booter/ForkedBooter.java:

       runSuitesInProcess( testSet, testClassLoader, startupConfiguration, providerConfiguration );
       // Say bye.
       System.out.println("Z,0,BYE!");
       System.out.flush();
       // noinspection CallToSystemExit
       System.exit( 0 );
      

      This happens at every run, just reverting surefire to 2.11 fixes the issue. If I use forkMode=never, it works, but our code needs a forked VM, otherwise we have SecurityManager issues.

      The surefire configuration itself is very basic:

      <plugin>
      	<groupId>org.apache.maven.plugins</groupId>
      	<artifactId>maven-surefire-plugin</artifactId>
      	<version>2.12</version>
      	<configuration>
      		<argLine>-Xms128m -Xmx1024m</argLine>
      		<includes>
      			<include>**/SelfHostingTests.java</include>
      		</includes>
      	</configuration>
      </plugin>
      

      Attached is the full build log with -X.

        Activity

        Kristian Rosenvold added a comment -

        SUREFIRE-836 was just fixed, and I see you're mentioning a security manager. Care to test 2.13-SNAPSHOT and see if it fixes the problem ?

        François LEIBER added a comment -

        OK I'll test it.

        Kristian Rosenvold added a comment -

        I'm closing this as a duplicate of SUREFIRE-836. Feel free to reopen with further info if necessary


          People

          • Assignee:
            Kristian Rosenvold
            Reporter:
            François LEIBER
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: