Maven Surefire
  1. Maven Surefire
  2. SUREFIRE-827

Surefire 2.12 cannot run a single test, regression from 2.11

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.12
    • Fix Version/s: 2.12.1
    • Labels:
      None
    • Environment:
      Ubuntu 11.10
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      1. Surefire 2.11
        $ mvn test -Dtest=DataTest#testDataServerGetNonExistentFile
        ...
        Tests run: 1, Failures: 0, Errors: 0, Skipped: 0
      1. Surefire 2.12
        mvn test -Dtest=DataTest#testDataServerGetNonExistentFile
        ...
        Tests run: 9, Failures: 0, Errors: 0, Skipped: 0

        Issue Links

          Activity

          Kristian Rosenvold added a comment -

          @Andrew; I am unable to reproduce this on my linux mint installation. Unless you can supply a mini test-project (maybe modify the one already attached) that demonstrates this I will close this issue as cannot reproduce.

          All the ms-windows users chiming in on this issue should note this has been fixed for windows.

          FWIW I tried this pom:

          <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
          <modelVersion>4.0.0</modelVersion>
          <groupId>SUREFIRE</groupId>
          <artifactId>BUG-827</artifactId>
          <version>0.0.1-SNAPSHOT</version>
          <dependencies>
          <dependency>
          <groupId>junit</groupId>
          <artifactId>junit</artifactId>
          <version>4.10</version>
          </dependency>
          </dependencies>
          <properties><surefire.version>2.12</surefire.version></properties>
          <build>
          <pluginManagement>
          <plugins>
          <plugin>
          <groupId>org.apache.maven.plugins</groupId>
          <artifactId>maven-surefire-plugin</artifactId>
          <version>$

          {surefire.version}

          </version>
          <configuration>
          <parallel>classes</parallel>
          <threadCount>2</threadCount>
          </configuration>
          </plugin>
          </plugins>
          </pluginManagement>
          </build>
          </project>

          Andrew Gaul added a comment -

          Kristian, going back to my example on 06 Feb 2012 with Apache commons-lang 3.1:

          $ mvn test -Dtest=ImmutablePairTest#testBasic -Dparallel=classes -Dsurefire.version=2.11
          ...
          Tests run: 1, Failures: 0, Errors: 0, Skipped: 0

          $ mvn test -Dtest=ImmutablePairTest#testBasic -Dparallel=classes -Dsurefire.version=2.12
          ...
          Tests run: 6, Failures: 0, Errors: 0, Skipped: 0

          $ mvn test -Dtest=ImmutablePairTest#testBasic -Dparallel=classes -Dsurefire.version=2.13-SNAPSHOT
          ...
          Tests run: 6, Failures: 0, Errors: 0, Skipped: 0

          Tested with maven-surefire-plugin-2.13-20120706.132117-19.jar .

          Kristian Rosenvold added a comment -

          This issue was caused by the ClassDemarcatingRunne introduced in SUREFIRE-800, which cased a whole host of issues. Removed CDR

          Kristian Rosenvold added a comment -

          Fixed in r1364159

          Andrew Gaul added a comment -

          Verified fixed in r1364394. Thank you for your persistence Kristian.


            People

            • Assignee:
              Kristian Rosenvold
              Reporter:
              Andrew Gaul
            • Votes:
              26 Vote for this issue
              Watchers:
              28 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: