Maven Surefire
  1. Maven Surefire
  2. SUREFIRE-714

maven-surefire-report-plugin version 2.8 generates the error org.apache.maven.doxia.siterenderer.sink.SiteRendererSink.unknown

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Not A Bug
    • Affects Version/s: 2.8
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Linux CentOS, Windows XP, Java 1.6.0_19.
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Running 'mvn site:site' with maven-surefire-report-plugin version 2.8 generates the following exception in our project:

      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] org.apache.maven.doxia.siterenderer.sink.SiteRendererSink.unknown(Ljava/lang/String;[Ljava/lang/Object;Lorg/apache/maven/doxia/sink/SinkEventAttributes;)V
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.AbstractMethodError: org.apache.maven.doxia.siterenderer.sink.SiteRendererSink.unknown(Ljava/lang/String;[Ljava/lang/Object;Lorg/apache/maven/doxia/sink/SinkEventAttributes;)V
      at org.apache.maven.plugins.surefire.report.SurefireReportGenerator.doGenerateReport(SurefireReportGenerator.java:76)
      at org.apache.maven.plugins.surefire.report.SurefireReportMojo.executeReport(SurefireReportMojo.java:200)
      at org.apache.maven.reporting.AbstractMavenReport.generate(AbstractMavenReport.java:190)
      at org.apache.maven.reporting.AbstractMavenReport.generate(AbstractMavenReport.java:144)
      at org.apache.maven.plugins.site.ReportDocumentRenderer.renderDocument(ReportDocumentRenderer.java:139)
      at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.renderModule(DefaultSiteRenderer.java:269)
      at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.render(DefaultSiteRenderer.java:101)
      at org.apache.maven.plugins.site.SiteMojo.renderLocale(SiteMojo.java:133)
      at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:100)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:569)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:539)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)

      Here is the relevant section of our pom file:

      <plugin>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-surefire-report-plugin</artifactId>
      <version>2.8/version>
      <configuration>
      <argLine>-Xmx512m</argLine>
      </configuration>
      </plugin>

      This does not happen with version 2.7.2, so we have temporarily switched back to version 2.7.2 for now.

      Does anyone know what is causing the problem? The release notes for version 2.8 does not give any hints.

      Thanks,
      Hansen

        Activity

        Kristian Rosenvold added a comment - - edited

        As can be seen from http://maven.apache.org/plugins/maven-surefire-report-plugin/

        "Note: As of version 2.8 this plugin requires Maven Site Plugin 2.1 or higher to work properly. Version 2.7.2 and older are still compatible with newer surefire versions, so mixing is possible."

        For all practical purposes you can stay on 2.7.2 as long as you want, since the xml format used for interchange will stay backward compatible (newer surefire versions can use older surefire-report-plugins). You will, of course, be missing out on bugfixes in reporting if you choose to not upgrade reporting-plugin/site.

        It's only indirectly expressed in the release notes through SUREFIRE-566, and I'll take note to be clearer on that next time. Thanks.


          People

          • Assignee:
            Kristian Rosenvold
            Reporter:
            Hansen Candrawinata
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: