Maven Surefire
  1. Maven Surefire
  2. SUREFIRE-640

org.apache.maven.surefire.booter.shade.org.codehaus.plexus.util.cli.CommandLineException: Error inside systemErr parser

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.7
    • Component/s: None
    • Labels:
      None
    • Environment:
      Maven 2.2.1
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Since update to Surefire 2.6 our CI server is breaking builds every now and then with:
      ...
      Results :
      Tests run: 42, Failures: 0, Errors: 0, Skipped: 0
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error while executing forked tests.; nested exception is org.apache.maven.surefire.booter.shade.org.codehaus.plexus.util.cli.CommandLineException: Error inside systemErr parser
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      ...

      Up to now I was not able to reproduce the issue. It looks like a concurrency issue.
      Configuration:
      <configuration>
      <systemPropertyVariables>
      <net.sourceforge.cobertura.datafile>target/cobertura/cobertura.ser</net.sourceforge.cobertura.datafile>
      <java.awt.headless>true</java.awt.headless>
      </systemPropertyVariables>
      <redirectTestOutputToFile>true</redirectTestOutputToFile>
      </configuration>
      Probably due to 42 tests

        Issue Links

          Activity

          Kristian Rosenvold added a comment -

          As far as I understand this issue has been hidden by the incorrect error handling in plexus-utils, which was fixed in PLXUTILS-131. I see a clear concurrency problem that should only be visible when redirectTestOutputToFile is true. Could you verify that the problem goes away if you disable this feature ?

          Michael Hinterseher added a comment -

          I removed redirectTestOutputToFile. I will post in case the problem occurs again.

          Michal Galet added a comment -

          Hi,

          I have the same problem. When I set redirectTestOutputToFile to true the build fails with this Error. It happens for both Maven 2.2.1 and 3.0.0 using surefire plugin 2.6.

          Kristian Rosenvold added a comment -

          Fixed several fairly obvious threading problems in r1030636.

          Kristian Rosenvold added a comment -

          There is a decent possiblity these problems have the same root cause, although the overload broad catch-block that was removed in Plexus-utils could potentially hide several problems.


            People

            • Assignee:
              Kristian Rosenvold
              Reporter:
              Michael Hinterseher
            • Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: