SonarQube Runner
  1. SonarQube Runner
  2. SONARUNNER-67

Fresh installation of Sonar Runner doesn't work on Mac OS X 10.8.3

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.2.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Mac OS X 10.8.3
    • Number of attachments :
      0

      Description

      Steps to reproduce: download sonar-runner, do not set SONAR_RUNNER_HOME, execute "./sonar-runner --help"

      $SONAR_RUNNER_HOME does not point to a valid installation directory: //
      

      Seems that this is a regression due to SONARPLUGINS-2313, because after removal of usage "real_path" command succeeds.

        Issue Links

          Activity

          Fabrice Bellingard added a comment -

          Looks like:

            # resolve symlinks
            PRG=`real_path "$PRG"`
          

          should be replaced by:

            # resolve symlinks
            if [ -h "$PRG" ] ; then
              PRG=`real_path "$PRG"`
            fi
          

          To test:

          • do not set the SONAR_RUNNER_HOME env variable
          • add a fake-runner sym link (that points to sonar-runner) in your path and try to run "fake-runner -v" somewhere
          Jean-Baptiste Vilain added a comment -

          The sonar-runner execution script has been updated as described above.

          Jean-Baptiste Vilain added a comment -

          No IT for that issue.


            People

            • Assignee:
              Julien HENRY
              Reporter:
              Evgeny Mandrikov
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: