SonarQube Runner
  1. SonarQube Runner
  2. SONARUNNER-21

Trailing slash on Windows XP prevent Sonar Runner to run

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3
    • Labels:
    • Number of attachments :
      0

      Description

      If SONAR_RUNNER_HOME have a trailing slash, it does not run with :

      C:\Projects\symfony>\sonar-runner-1.2\bin\sonar-runner.bat
      C:\sonar-runner-1.2\
      Usage: java [-options] class [args...]
                 (to execute a class)
         or  java [-options] -jar jarfile [args...]
                 (to execute a jar file)
      
      where options include:
          -client       to select the "client" VM
          -server       to select the "server" VM
          -hotspot      is a synonym for the "client" VM  [deprecated]
                        The default VM is client.
      
          -cp <class search path of directories and zip/jar files>
          -classpath <class search path of directories and zip/jar files>
                        A ; separated list of directories, JAR archives,
                        and ZIP archives to search for class files.
          -D<name>=<value>
                        set a system property
          -verbose[:class|gc|jni]
                        enable verbose output
          -version      print product version and exit
          -version:<value>
                        require the specified version to run
          -showversion  print product version and continue
          -jre-restrict-search | -jre-no-restrict-search
                        include/exclude user private JREs in the version search
          -? -help      print this help message
          -X            print help on non-standard options
      ...
      

        Activity

        Freddy Mallet added a comment -

        Works well Fabrice but looks like there is a side effect. Indeed when the SONAR_RUNNER_HOME env variable is not defined I get the following error :

        "-1 was unexpected at this time"

        Fabrice Bellingard added a comment -

        Regression fixed.

        Freddy Mallet added a comment -

        Works well Fabrice !

        Fabrice Bellingard added a comment -

        No need for IT.


          People

          • Assignee:
            Fabrice Bellingard
            Reporter:
            Fabrice Bellingard
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: