Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: TECHDEBT-1.0.1
    • Fix Version/s: TECHDEBT-1.2
    • Component/s: Technical Debt
    • Labels:
      None
    • Environment:
      Red Hat Enterprise Linux 5.4 Tikanga, 32-bit, Hudson 1.386, Sonar 2.4.1, Technical Debt Plugin 1.0.1
    • Number of attachments :
      1

      Description

      After:

      • upgrading Sonar from 2.3.1 to 2.4.1
      • AND upgrading Technical Debt Plugin 1.0 to 1.0.1
      • AND setting the "Maximum complexity" setting to "METHOD=10"

      The build breaks during Sonar project analysis with the following stacktrace:
      Caused by: java.lang.NullPointerException
      at org.sonar.plugins.technicaldebt.ComplexityDebtSensor.computeAndSaveDistributionForFiles(ComplexityDebtSensor.java:70)
      at org.sonar.plugins.technicaldebt.ComplexityDebtSensor.analyse(ComplexityDebtSensor.java:63)
      at org.sonar.batch.SensorsExecutor.execute(SensorsExecutor.java:58)
      at org.sonar.batch.ProjectBatch.execute(ProjectBatch.java:59)

      Please see entire Maven build log + entire stacktrace in attachment.

        Activity

        Ruud de Jong added a comment -

        After changing the "Maximum complexity" setting to "CLASS=60;METHOD=10" instead of "METHOD=10, the problem no longer appears.
        Apparently, when using this setting CLASS and METHOD are both mandatory.

        Ruud de Jong added a comment -

        Since an easy workaround is available now, the priority can be lowered to "minor".
        But I cannot seem to find the "change priority" setting anywhere.
        Can someone do this for me?


          People

          • Assignee:
            Simon Brandhof
            Reporter:
            Ruud de Jong
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: