SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-866

Plugin does not accept absolute path as src directory

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: WEB-1.0.1
    • Fix Version/s: WEB-1.1
    • Component/s: Web
    • Labels:
      None
    • Number of attachments :
      0

      Issue Links

        Activity

        Matthijs Galesloot added a comment -

        This issue was rejected in SONARPLUGINS-837 as it does not fit with the best practices for continuous integration.

        Matthijs Galesloot added a comment -

        Evgeny

        Please comment on the issue and assign back to me.

        This is the 2d time we get a request for absolute paths. Should we do it?

        Evgeny Mandrikov added a comment -

        I didn't changed my mind - absolute path in POM leads to problems with reproducibility of builds. But maybe this issue isn't about this, because "$

        {basedir}

        /src" is also absolute path So in any case it's better to ask reporter - Olivier.


          People

          • Assignee:
            Matthijs Galesloot
            Reporter:
            Olivier Gaudin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: