SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-816

Profile "integration-tests" uses failsafe-maven-plugin instead of maven-failsafe-plugin

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: PARENT-7
    • Fix Version/s: PARENT-8
    • Component/s: Parent
    • Labels:
      None
    • Number of attachments :
      0

      Description

      This causes failures during integration tests due to enforcer rules :

      [INFO] [enforcer:enforce {execution: enforce}]
      [WARNING] Rule 3: org.apache.maven.plugins.enforcer.RequirePluginVersions failed with message:
      Some plugins are missing valid versions:(LATEST RELEASE SNAPSHOT are not allowed )
      org.codehaus.mojo:failsafe-maven-plugin.        The version currently in use is 2.4.3-alpha-1
      Build reproducibility : always define plugin versions!
      

        Activity

        Hide
        Evgeny Mandrikov added a comment -

        Fixed in r2680.

        Show
        Evgeny Mandrikov added a comment - Fixed in r2680 .

          People

          • Assignee:
            Evgeny Mandrikov
            Reporter:
            Evgeny Mandrikov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: