Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: GROOVY-0.1
    • Fix Version/s: GROOVY-0.3
    • Component/s: Groovy
    • Labels:
      None
    • Number of attachments :
      0

      Description

      CodeNarc reports a line of "" when a violation is attached to the class. The plugin is unable to handle this. Ex : cyclomatic complexity rule

        Issue Links

          Activity

          Evgeny Mandrikov added a comment -

          This issue can't be reproduced with cyclomatic complexity rule and CodeNarc 0.12 ( SONARPLUGINS-697 ), since it provides correct line number.

          Evgeny Mandrikov added a comment -

          Fixed in r3690.


            People

            • Assignee:
              Evgeny Mandrikov
              Reporter:
              Olivier Gaudin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: