SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-530

com.mysql.jdbc.MysqlDataTruncation: Data truncation: Out of range value adjusted for column 'value' at row 1

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: BUILD-STABILITY-1.1
    • Fix Version/s: None
    • Component/s: Build Stability
    • Labels:
      None
    • Environment:
      java version "1.6.0_17"
      Java(TM) SE Runtime Environment (build 1.6.0_17-b04)
      Java HotSpot(TM) 64-Bit Server VM (build 14.3-b01, mixed mode)
      Maven 2.2.1
      Hudson 1.357
      Ubuntu 8.04 with Linux 2.6.27.13 kernel
    • Number of attachments :
      0

      Description

      A nightly build started to fail some days ago with the message "com.mysql.jdbc.MysqlDataTruncation: Data truncation: Out of range value adjusted for column 'value' at row 1".
      See comments for console logs.

        Activity

        Andreas Hochsteger added a comment -

        [INFO] Sensor org.sonar.plugins.buildstability.BuildStabilitySensor@74d1c564...
        [INFO] CI URL: Hudson:http://develop/hudson/job/um/
        [INFO] Retrieved 101 builds since Sat May 01 00:18:37 CEST 2010
        [WARN] SQL Error: 0, SQLState: 22001
        [ERROR] Data truncation: Out of range value adjusted for column 'value' at row 1
        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD ERROR
        [INFO] ------------------------------------------------------------------------
        [INFO] Can not execute Sonar

        Embedded error: Can not analyze the project
        Data truncation: Out of range value adjusted for column 'value' at row 1
        [INFO] ------------------------------------------------------------------------
        [INFO] Trace
        org.apache.maven.lifecycle.LifecycleExecutionException: Can not execute Sonar
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:569)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:539)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:284)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
        Caused by: org.apache.maven.plugin.MojoExecutionException: Can not execute Sonar
        at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:87)
        at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65)
        at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:117)
        at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
        ... 17 more
        Caused by: org.apache.maven.plugin.MojoExecutionException: Can not analyze the project
        at org.sonar.maven2.BatchMojo.executeBatch(BatchMojo.java:152)
        at org.sonar.maven2.BatchMojo.execute(BatchMojo.java:131)
        at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
        at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:82)
        ... 21 more
        Caused by: javax.persistence.PersistenceException: org.hibernate.exception.DataException: could not insert: [org.sonar.api.database.model.MeasureModel]
        at org.hibernate.ejb.AbstractEntityManagerImpl.throwPersistenceException(AbstractEntityManagerImpl.java:614)
        at org.hibernate.ejb.AbstractEntityManagerImpl.persist(AbstractEntityManagerImpl.java:226)
        at org.sonar.api.database.DatabaseSession.internalSave(DatabaseSession.java:118)
        at org.sonar.api.database.DatabaseSession.save(DatabaseSession.java:95)
        at org.sonar.api.database.model.MeasureModel.save(MeasureModel.java:520)
        at org.sonar.batch.indexer.DefaultSonarIndex.persistMeasure(DefaultSonarIndex.java:296)
        at org.sonar.batch.indexer.DefaultSonarIndex.addMeasure(DefaultSonarIndex.java:269)
        at org.sonar.batch.indexer.DefaultSonarIndex.saveMeasure(DefaultSonarIndex.java:257)
        at org.sonar.batch.DefaultSensorContext.saveMeasure(DefaultSensorContext.java:62)
        at org.sonar.plugins.buildstability.BuildStabilitySensor.analyseBuilds(BuildStabilitySensor.java:156)
        at org.sonar.plugins.buildstability.BuildStabilitySensor.analyse(BuildStabilitySensor.java:87)
        at org.sonar.batch.SensorsExecutor.execute(SensorsExecutor.java:58)
        at org.sonar.batch.ProjectBatch.execute(ProjectBatch.java:53)
        at org.sonar.batch.AggregatorBatch.analyzeProject(AggregatorBatch.java:109)
        at org.sonar.batch.AggregatorBatch.analyzeProjects(AggregatorBatch.java:101)
        at org.sonar.batch.AggregatorBatch.execute(AggregatorBatch.java:85)
        at org.sonar.maven2.BatchMojo.executeBatch(BatchMojo.java:149)
        ... 24 more
        Caused by: org.hibernate.exception.DataException: could not insert: [org.sonar.api.database.model.MeasureModel]
        at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:100)
        at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:66)
        at org.hibernate.id.insert.AbstractReturningDelegate.performInsert(AbstractReturningDelegate.java:64)
        at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2176)
        at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2656)
        at org.hibernate.action.EntityIdentityInsertAction.execute(EntityIdentityInsertAction.java:71)
        at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:279)
        at org.hibernate.event.def.AbstractSaveEventListener.performSaveOrReplicate(AbstractSaveEventListener.java:321)
        at org.hibernate.event.def.AbstractSaveEventListener.performSave(AbstractSaveEventListener.java:204)
        at org.hibernate.event.def.AbstractSaveEventListener.saveWithGeneratedId(AbstractSaveEventListener.java:130)
        at org.hibernate.ejb.event.EJB3PersistEventListener.saveWithGeneratedId(EJB3PersistEventListener.java:49)
        at org.hibernate.event.def.DefaultPersistEventListener.entityIsTransient(DefaultPersistEventListener.java:154)
        at org.hibernate.event.def.DefaultPersistEventListener.onPersist(DefaultPersistEventListener.java:110)
        at org.hibernate.event.def.DefaultPersistEventListener.onPersist(DefaultPersistEventListener.java:61)
        at org.hibernate.impl.SessionImpl.firePersist(SessionImpl.java:646)
        at org.hibernate.impl.SessionImpl.persist(SessionImpl.java:620)
        at org.hibernate.impl.SessionImpl.persist(SessionImpl.java:624)
        at org.hibernate.ejb.AbstractEntityManagerImpl.persist(AbstractEntityManagerImpl.java:220)
        ... 39 more
        Caused by: com.mysql.jdbc.MysqlDataTruncation: Data truncation: Out of range value adjusted for column 'value' at row 1
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3489)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3423)
        at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1936)
        at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2060)
        at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2542)
        at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:1734)
        at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:2019)
        at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:1937)
        at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:1922)
        at org.hibernate.id.IdentityGenerator$GetGeneratedKeysDelegate.executeAndExtract(IdentityGenerator.java:94)
        at org.hibernate.id.insert.AbstractReturningDelegate.performInsert(AbstractReturningDelegate.java:57)
        ... 54 more
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 4 minutes 41 seconds
        [INFO] Finished at: Mon May 31 00:19:04 CEST 2010
        [INFO] Final Memory: 121M/289M
        [INFO] ------------------------------------------------------------------------

        Andreas Hochsteger added a comment -

        When invoking the sonar analysis build with "-Dsonar.hibernate.show_sql=true -Dsonar.hibernate.format_sql=true" the following SQL statements can be seen:

        [INFO] Sensor org.sonar.plugins.buildstability.BuildStabilitySensor@74d1c564...
        [INFO] CI URL: Hudson:http://develop/hudson/job/um/
        [INFO] Retrieved 101 builds since Sat May 01 00:18:37 CEST 2010
        Hibernate:
        select
        metric0_.id as id4_,
        metric0_.best_value as best2_4_,
        metric0_.description as descript3_4_,
        metric0_.direction as direction4_,
        metric0_.domain as domain4_,
        metric0_.enabled as enabled4_,
        metric0_.hidden as hidden4_,
        metric0_.name as name4_,
        metric0_.short_name as short9_4_,
        metric0_.optimized_best_value as optimized10_4_,
        metric0_.origin as origin4_,
        metric0_.qualitative as qualita12_4_,
        metric0_.val_type as val13_4_,
        metric0_.user_managed as user14_4_,
        metric0_.worst_value as worst15_4_
        from
        metrics metric0_
        Hibernate:
        insert
        into
        project_measures
        (alert_status, alert_text, description, diff_value_1, diff_value_2, diff_value_3, measure_date, metric_id, project_id, rule_id, rule_priority, rules_category_id, snapshot_id, tendency, text_value, url, value)
        values
        (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
        Hibernate:
        insert
        into
        project_measures
        (alert_status, alert_text, description, diff_value_1, diff_value_2, diff_value_3, measure_date, metric_id, project_id, rule_id, rule_priority, rules_category_id, snapshot_id, tendency, text_value, url, value)
        values
        (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
        Hibernate:
        insert
        into
        project_measures
        (alert_status, alert_text, description, diff_value_1, diff_value_2, diff_value_3, measure_date, metric_id, project_id, rule_id, rule_priority, rules_category_id, snapshot_id, tendency, text_value, url, value)
        values
        (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
        Hibernate:
        insert
        into
        project_measures
        (alert_status, alert_text, description, diff_value_1, diff_value_2, diff_value_3, measure_date, metric_id, project_id, rule_id, rule_priority, rules_category_id, snapshot_id, tendency, text_value, url, value)
        values
        (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
        Hibernate:
        insert
        into
        project_measures
        (alert_status, alert_text, description, diff_value_1, diff_value_2, diff_value_3, measure_date, metric_id, project_id, rule_id, rule_priority, rules_category_id, snapshot_id, tendency, text_value, url, value)
        values
        (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
        Hibernate:
        insert
        into
        project_measures
        (alert_status, alert_text, description, diff_value_1, diff_value_2, diff_value_3, measure_date, metric_id, project_id, rule_id, rule_priority, rules_category_id, snapshot_id, tendency, text_value, url, value)
        values
        (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
        Hibernate:
        insert
        into
        project_measures
        (alert_status, alert_text, description, diff_value_1, diff_value_2, diff_value_3, measure_date, metric_id, project_id, rule_id, rule_priority, rules_category_id, snapshot_id, tendency, text_value, url, value)
        values
        (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
        Hibernate:
        insert
        into
        project_measures
        (alert_status, alert_text, description, diff_value_1, diff_value_2, diff_value_3, measure_date, metric_id, project_id, rule_id, rule_priority, rules_category_id, snapshot_id, tendency, text_value, url, value)
        values
        (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
        [WARN] SQL Error: 0, SQLState: 22001
        [ERROR] Data truncation: Out of range value adjusted for column 'value' at row 1
        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD ERROR
        [INFO] ------------------------------------------------------------------------
        [INFO] Can not execute Sonar

        Andreas Hochsteger added a comment -

        I did some research and found the following resources - maybe they help solving the problem:
        http://bugs.mysql.com/bug.php?id=23401
        http://bugs.mysql.com/bug.php?id=22290
        http://bugs.mysql.com/bug.php?id=7829

        Andreas Hochsteger added a comment -

        FYI: Since this is a very old bug report from me and I didn't see this problem for a long time it may be closed as not relevant anymore.


          People

          • Assignee:
            Unassigned
            Reporter:
            Andreas Hochsteger
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: