SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-494

MalformedURLException when first login attempt

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: CROWD-0.1
    • Fix Version/s: CROWD-0.2
    • Component/s: Crowd
    • Labels:
      None
    • Environment:
      OpenJDK Runtime Environment (IcedTea6 1.6.1)
      Sonar 2.1 (as standalone application)
      Crowd 1.6.1
    • Number of attachments :
      1

      Description

      When i start sonar, the crowd plugin seems fine, in the logs i get:
      2010.05.05 17:48:53 INFO org.sonar.INFO Start sonar...
      2010.05.05 17:48:54 INFO org.sonar.INFO Authentication plugin: class org.sonar.plugins.crowd.CrowdAuthenticator
      2010.05.05 17:48:54 INFO org.sonar.INFO Authentication plugin started
      2010.05.05 17:48:54 INFO org.sonar.INFO Deploy GWT plugins...

      When i try to login with my user, the authentication seems fine (or maybe it is because 'sonar.authenticator.createUsers' is true?), and i access to the landing page. But i get a huge stack trace into the logs (i paste it into a file)

      My crowd plugin settings are:

      sonar.authenticator.class: org.sonar.plugins.crowd.CrowdAuthenticator
      #sonar.authenticator.ignoreStartupFailure: true
      sonar.authenticator.createUsers: true
      # URL of the Crowd server (usually ends with /services/).
      crowd.url:http://crowd.company.com/services/
      # Crowd application name.
      # Default is 'sonar'.
      crowd.application:sonar_company
      # Crowd application password.
      crowd.password:sonar_secret
      

        Activity

        Vincent Ricard added a comment -

        Sorry for the wrong formatting, here is my crowd settings:

        sonar.authenticator.class: org.sonar.plugins.crowd.CrowdAuthenticator
        
        #sonar.authenticator.ignoreStartupFailure: true
        
        sonar.authenticator.createUsers: true
        
        # URL of the Crowd server (usually ends with /services/).
        crowd.url:http://crowd.company.com/services/
        
        # Crowd application name.
        # Default is 'sonar'.
        crowd.application:sonar_company
        
        # Crowd application password.
        crowd.password:sonar_secret
        
        
        Evgeny Mandrikov added a comment -

        Hi Vincent,

        Is this issue still actual? I'm asking, because looks like Crowd plugin works for you (see SONARPLUGINS-495).

        Also could you please discuss your problems in Sonar users mailing list before creating tickets in Jira in future? Because it can be not a bug, but a known behavior or wrong configuration and so on.

        Evgeny Mandrikov added a comment -

        I confirm that this problem still exists (Crowd 2.0.7, Sonar 2.3-SNAPSHOT, Sonar Crowd Plugin 0.2-SNAPSHOT):

        java.net.MalformedURLException
                at java.net.URL.<init>(URL.java:601) [na:1.6.0_20]
                at java.net.URL.<init>(URL.java:464) [na:1.6.0_20]
                at java.net.URL.<init>(URL.java:413) [na:1.6.0_20]
                at com.atlassian.crowd.integration.service.soap.client.BaseResourceLocator.getProperties(BaseResourceLocator.java:108) [crowd-integration-api-2.0.2.jar:na]
                at com.atlassian.crowd.integration.service.soap.client.ClientPropertiesImpl.<init>(ClientPropertiesImpl.java:43) [crowd-integration-api-2.0.2.jar:na]
                at com.atlassian.crowd.integration.service.soap.client.SecurityServerClientFactory.<clinit>(SecurityServerClientFactory.java:14) [crowd-integration-api-2.0.2.jar:na]
                at com.atlassian.crowd.integration.service.cache.CachingManagerFactory.getSSC(CachingManagerFactory.java:75) [crowd-integration-api-2.0.2.jar:na]
                at com.atlassian.crowd.integration.service.cache.CachingManagerFactory.access$000(CachingManagerFactory.java:13) [crowd-integration-api-2.0.2.jar:na]
                at com.atlassian.crowd.integration.service.cache.CachingManagerFactory$AuthenticationManagerHolder.<clinit>(CachingManagerFactory.java:21) [crowd-integration-api-2.0.2.jar:na]
                at com.atlassian.crowd.integration.service.cache.CachingManagerFactory.getAuthenticationManagerInstance(CachingManagerFactory.java:85) [crowd-integration-api-2.0.2.jar:na]
                at org.sonar.plugins.crowd.CrowdAuthenticator.authenticate(CrowdAuthenticator.java:53) [sonar-crowd-plugin-0.2-SNAPSHOT.jar:na]
        ...
        

        But looks like this exception occurs only on first login and don't prevents correct work.

        Vincent Ricard added a comment -

        Sorry, i answered on the ml that the bug still exists, but not here :-/

        The exception occurs only once, surely because there is a cache. I guess if we disable the cache (in the conf or in the code?), we'll have an exception for each attempt.

        Evgeny Mandrikov added a comment -

        Fixed in r2140, tested with Crowd 2.0.7 and Sonar 2.3-SNAPSHOT.


          People

          • Assignee:
            Evgeny Mandrikov
            Reporter:
            Vincent Ricard
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: