SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-435

Nullpointer in FlexCpdMavenSensor.java:152

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: FLEX-0.1
    • Component/s: Flex
    • Labels:
      None
    • Number of attachments :
      2

      Description

      Followed the steps mentioned here, and am unable to run the flex metrics. Attached the stack trace, seems to be a problem with the cpd check being null? Just taking a wild guess here.

      1. cpd.xml
        857 kB
        Kyle Lebel
      2. sonar-flex-npe.txt
        4 kB
        Kyle Lebel

        Activity

        Olivier Gaudin added a comment -

        I have identified the issue and will fix it tomorrow

        Kyle Lebel added a comment -

        Hey great! I'd be curious about the root cause. Thanks!

        Olivier Gaudin added a comment -

        Root cause is : FlexCPD analyzes MXML files, and Sonar does not !
        I have added a fix to avoid NPE, and this morning I am going to make extensions to handle a parameter

        Olivier Gaudin added a comment -

        Issue is resolved, snapshot version is available on the plugin page

        Kyle Lebel added a comment -

        Tried it out - our bigger project now builds fine. So that's good.

        However the smaller project still gets an error. Will open a new defect for that one.

        Thanks!


          People

          • Assignee:
            Olivier Gaudin
            Reporter:
            Kyle Lebel
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: