Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: MOJO-BRIDGE-0.1
    • Fix Version/s: MOJO-BRIDGE-0.1
    • Component/s: Mojo Bridge
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I am trying to use sonar-mojo-plugin with Sonar 3.7.1, but it is not 
      able to detect that I am running my plans with Maven 3 correctly and 
      keeps printing
      
      this plugin is incompatible with maven2, run again with maven3
      
      The problem is in the function:
      
      public static boolean checkIfIsMaven3(final MavenPluginExecutor mavenPluginExecutor) {
           try {
             return mavenPluginExecutor instanceof Maven3PluginExecutor;
           } catch (NoClassDefFoundError e) {
             // this happens when maven 2 is used
             return false;
           }
      }
      

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Lars Gohlke
            Reporter:
            Lars Gohlke
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: