Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: XML-1.0
    • Fix Version/s: XML-1.0.1
    • Component/s: XML
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Xalan is not packaged within core anymore in v4.0.

        Issue Links

          Activity

          Simon Brandhof added a comment -

          Integration tests pass on both versions 3.2 and 4.0.

          Freddy Mallet added a comment -

          Manually tested !

          Daniel Tremblay added a comment -

          I have the same issue with the Delphi plugin. JDK 1.6 running SonarQube 4.0, on Linux x86-32.

          INFO: ------------------------------------------------------------------------
          INFO: EXECUTION FAILURE
          INFO: ------------------------------------------------------------------------
          Total time: 41.686s
          Final Memory: 30M/285M
          INFO: ------------------------------------------------------------------------
          ERROR: Error during Sonar runner execution
          org.sonar.runner.impl.RunnerException: Unable to execute Sonar
          at org.sonar.runner.impl.BatchLauncher$1.delegateExecution(BatchLauncher.java:91)
          at org.sonar.runner.impl.BatchLauncher$1.run(BatchLauncher.java:75)
          at java.security.AccessController.doPrivileged(Native Method)
          at org.sonar.runner.impl.BatchLauncher.doExecute(BatchLauncher.java:69)
          at org.sonar.runner.impl.BatchLauncher.execute(BatchLauncher.java:50)
          at org.sonar.runner.api.EmbeddedRunner.doExecute(EmbeddedRunner.java:102)
          at org.sonar.runner.api.Runner.execute(Runner.java:90)
          at org.sonar.runner.Main.executeTask(Main.java:70)
          at org.sonar.runner.Main.execute(Main.java:59)
          at org.sonar.runner.Main.main(Main.java:41)
          Caused by: java.lang.NoClassDefFoundError: org/apache/xpath/objects/XNodeSet
          at java.lang.Class.getDeclaredConstructors0(Native Method)
          at java.lang.Class.privateGetDeclaredConstructors(Class.java:2398)
          at java.lang.Class.getConstructor0(Class.java:2708)
          at java.lang.Class.newInstance0(Class.java:328)
          at java.lang.Class.newInstance(Class.java:310)
          at net.sourceforge.pmd.RuleSetFactory.parseSingleRuleNode(RuleSetFactory.java:309)
          at net.sourceforge.pmd.RuleSetFactory.parseRuleNode(RuleSetFactory.java:253)
          at net.sourceforge.pmd.RuleSetFactory.parseRuleSetNode(RuleSetFactory.java:209)
          at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:157)
          at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:146)
          at org.sonar.plugins.delphi.pmd.DelphiPmdSensor.createRuleSets(DelphiPmdSensor.java:82)
          at org.sonar.plugins.delphi.pmd.DelphiPmdSensor.createPmdReport(DelphiPmdSensor.java:90)
          at org.sonar.plugins.delphi.pmd.DelphiPmdSensor.analyse(DelphiPmdSensor.java:72)
          at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:72)
          at org.sonar.batch.phases.PhaseExecutor.execute(PhaseExecutor.java:114)
          at org.sonar.batch.scan.ModuleScanContainer.doAfterStart(ModuleScanContainer.java:150)
          at org.sonar.api.platform.ComponentContainer.startComponents(ComponentContainer.java:92)
          at org.sonar.api.platform.ComponentContainer.execute(ComponentContainer.java:77)
          at org.sonar.batch.scan.ProjectScanContainer.scan(ProjectScanContainer.java:190)
          at org.sonar.batch.scan.ProjectScanContainer.scanRecursively(ProjectScanContainer.java:185)
          at org.sonar.batch.scan.ProjectScanContainer.doAfterStart(ProjectScanContainer.java:178)
          at org.sonar.api.platform.ComponentContainer.startComponents(ComponentContainer.java:92)
          at org.sonar.api.platform.ComponentContainer.execute(ComponentContainer.java:77)
          at org.sonar.batch.scan.ScanTask.scan(ScanTask.java:58)
          at org.sonar.batch.scan.ScanTask.execute(ScanTask.java:45)
          at org.sonar.batch.bootstrap.TaskContainer.doAfterStart(TaskContainer.java:82)
          at org.sonar.api.platform.ComponentContainer.startComponents(ComponentContainer.java:92)
          at org.sonar.api.platform.ComponentContainer.execute(ComponentContainer.java:77)
          at org.sonar.batch.bootstrap.BootstrapContainer.executeTask(BootstrapContainer.java:155)
          at org.sonar.batch.bootstrap.BootstrapContainer.doAfterStart(BootstrapContainer.java:143)
          at org.sonar.api.platform.ComponentContainer.startComponents(ComponentContainer.java:92)
          at org.sonar.api.platform.ComponentContainer.execute(ComponentContainer.java:77)
          at org.sonar.batch.bootstrapper.Batch.startBatch(Batch.java:92)
          at org.sonar.batch.bootstrapper.Batch.execute(Batch.java:74)
          at org.sonar.runner.batch.IsolatedLauncher.execute(IsolatedLauncher.java:45)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.sonar.runner.impl.BatchLauncher$1.delegateExecution(BatchLauncher.java:87)
          ... 9 more
          Caused by: java.lang.ClassNotFoundException: org.apache.xpath.objects.XNodeSet
          at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)
          at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:244)
          at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:230)


            People

            • Assignee:
              Simon Brandhof
              Reporter:
              Simon Brandhof
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved: