Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JIRA-0.1
    • Fix Version/s: JIRA-0.2
    • Component/s: Jira
    • Labels:
      None
    • Environment:
      Sonar: Linux
    • Number of attachments :
      0

      Description

      I have cofigured Sonar with correct JIRA url, user&password.

      During build the only information i have

      [INFO]  Executing sensor class org.sonar.plugins.jira.JiraSensor
      [ERROR]  Error accessing Jira web service, please verify the parameters. Returned error is 'null'
      

      Please help me to identify the root cause problem for this and/or point me the directions to look for (debug level parameters etc ...)

        Activity

        Leonid Maslov added a comment -

        Please consider to improve logging in terms of

        try{
        ..
         } catch (Exception e) {
                LOG.error("Error accessing Jira web service, please verify the parameters. Returned error is '{}'", e.getMessage());
              }
        


        Logging not only e.getMessage() but all the stacktrace as well. (in all other places as well)
        Thanks in advance!

        Evgeny Mandrikov added a comment -

        I suppose that this is not a bug, but an improvement.


          People

          • Assignee:
            Evgeny Mandrikov
            Reporter:
            Leonid Maslov
          • Votes:
            3 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: