SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-2740

Caused by: java.lang.IllegalArgumentException: Measure value can not be NaN

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: SONARJ-2.2.1
    • Fix Version/s: SONARGRAPH-3.1
    • Component/s: Sonargraph
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Running analysis on project: https://git-wip-us.apache.org/repos/asf?p=isis.git
      Stack trace:

      Caused by: org.sonar.api.utils.SonarException: Fail to decorate 'org.sonar.api.resources.Project@2422caf0[id=127645,key=org.apache.isis.core:isis,qualifier=BRC]'
      	at org.sonar.batch.phases.DecoratorsExecutor.executeDecorator(DecoratorsExecutor.java:84)
      	at org.sonar.batch.phases.DecoratorsExecutor.decorateResource(DecoratorsExecutor.java:70)
      	at org.sonar.batch.phases.DecoratorsExecutor.execute(DecoratorsExecutor.java:55)
      	at org.sonar.batch.phases.Phases.execute(Phases.java:92)
      	at org.sonar.batch.bootstrap.ProjectModule.doStart(ProjectModule.java:129)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:68)
      	at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:147)
      	at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:141)
      	at org.sonar.batch.bootstrap.BatchModule.doStart(BatchModule.java:136)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:68)
      	at org.sonar.batch.bootstrap.BootstrapModule.doStart(BootstrapModule.java:83)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:68)
      	at org.sonar.batch.bootstrapper.Batch.startBatch(Batch.java:75)
      	at org.sonar.batch.bootstrapper.Batch.execute(Batch.java:60)
      	at org.sonar.maven3.SonarMojo.execute(SonarMojo.java:142)
      	at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:113)
      	... 23 more
      Caused by: java.lang.IllegalArgumentException: Measure value can not be NaN
      	at org.sonar.api.measures.Measure.setValue(Measure.java:278)
      	at org.sonar.api.measures.Measure.setValue(Measure.java:250)
      	at org.sonar.api.measures.Measure.<init>(Measure.java:83)
      	at org.sonar.batch.DefaultDecoratorContext.saveMeasure(DefaultDecoratorContext.java:117)
      	at com.hello2morrow.sonarplugin.decorator.SonargraphDerivedMetricsDecorator.saveCyclicityMeasures(SonargraphDerivedMetricsDecorator.java:144)
      	at com.hello2morrow.sonarplugin.decorator.SonargraphDerivedMetricsDecorator.decorate(SonargraphDerivedMetricsDecorator.java:87)
      	at org.sonar.batch.phases.DecoratorsExecutor.executeDecorator(DecoratorsExecutor.java:79)
      	... 38 more
      

      Command line used (tru Sonar Jenkins plugin):
      /xxxxx/maven-3.0.4/bin/mvn -f /x1/jenkins/jenkins-master/jenkins-home/jobs/isis/workspace/pom.xml -e -B sonar:sonar -Dsonar.jdbc.driver=com.mysql.jdbc.Driver -Dsonar.jdbc.url=jdbc:mysql://xxxx:yyy/sonar?useUnicode=true&characterEncoding=utf8 ******** ******** -Dsonar.host.url=https://analysis.apache.org

        Activity

        Freddy Mallet added a comment -

        Hi @Olivier, this bug is due to the SonarGraph plugin from Hello2Morrow.

        Ingmar Kellner added a comment -

        Duplicate of SONARPLUGINS-2732.


          People

          • Assignee:
            Ingmar Kellner
            Reporter:
            Olivier Lamy
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: