SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-2618

Plugin incompatible with non-maven projects

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: MOJO-BRIDGE-0.1
    • Fix Version/s: MOJO-BRIDGE-0.1
    • Component/s: Mojo Bridge
    • Labels:
      None
    • Number of attachments :
      0

      Description

      problem running sonar analysis with sonar runner

      09:57:11.995 INFO        org.sonar.INFO - Compare over 30 days (2012-12-16)
      Total time: 6.202s
      Final Memory: 12M/214M
      Exception in thread "main" org.sonar.runner.RunnerException: org.picocontainer.injectors.AbstractInjector$UnsatisfiableDependenciesException: de.lgohlke.sonar.PomSourceImporter has unsatisfied dependency 'class org.apache.maven.project.MavenProject' for constructor 'public de.lgohlke.sonar.PomSourceImporter(org.apache.maven.project.MavenProject)' from org.picocontainer.DefaultPicoContainer@5236b222:210<[Immutable]:org.picocontainer.DefaultPicoContainer@13743ac:278<[Immutable]:org.picocontainer.DefaultPicoContainer@5801e99a:18<|
          at org.sonar.runner.Runner.delegateExecution(Runner.java:288)
          at org.sonar.runner.Runner.execute(Runner.java:151)
          at org.sonar.runner.Main.execute(Main.java:84)
          at org.sonar.runner.Main.main(Main.java:56)
      Caused by: org.picocontainer.injectors.AbstractInjector$UnsatisfiableDependenciesException: de.lgohlke.sonar.PomSourceImporter has unsatisfied dependency 'class org.apache.maven.project.MavenProject' for constructor 'public de.lgohlke.sonar.PomSourceImporter(org.apache.maven.project.MavenProject)' from org.picocontainer.DefaultPicoContainer@5236b222:210<[Immutable]:org.picocontainer.DefaultPicoContainer@13743ac:278<[Immutable]:org.picocontainer.DefaultPicoContainer@5801e99a:18<|
          at org.picocontainer.injectors.ConstructorInjector.getGreediestSatisfiableConstructor(ConstructorInjector.java:197)
          at org.picocontainer.injectors.ConstructorInjector.getGreediestSatisfiableConstructor(ConstructorInjector.java:112)
          at org.picocontainer.injectors.ConstructorInjector.access$100(ConstructorInjector.java:52)
          at org.picocontainer.injectors.ConstructorInjector$1.run(ConstructorInjector.java:337)
          at org.picocontainer.injectors.AbstractInjector$ThreadLocalCyclicDependencyGuard.observe(AbstractInjector.java:272)
          at org.picocontainer.injectors.ConstructorInjector.getComponentInstance(ConstructorInjector.java:370)
          at org.picocontainer.injectors.AbstractInjectionFactory$LifecycleAdapter.getComponentInstance(AbstractInjectionFactory.java:56)
          at org.picocontainer.behaviors.AbstractBehavior.getComponentInstance(AbstractBehavior.java:64)
          at org.picocontainer.behaviors.Stored.getComponentInstance(Stored.java:91)
          at org.picocontainer.DefaultPicoContainer.getLocalInstance(DefaultPicoContainer.java:606)
          at org.picocontainer.DefaultPicoContainer.getComponents(DefaultPicoContainer.java:587)
          at org.sonar.api.platform.ComponentContainer.getComponentsByType(ComponentContainer.java:123)
          at org.sonar.api.batch.BatchExtensionDictionnary.completeBatchExtensions(BatchExtensionDictionnary.java:91)
          at org.sonar.api.batch.BatchExtensionDictionnary.getExtensions(BatchExtensionDictionnary.java:85)
          at org.sonar.api.batch.BatchExtensionDictionnary.getFilteredExtensions(BatchExtensionDictionnary.java:98)
          at org.sonar.api.batch.BatchExtensionDictionnary.select(BatchExtensionDictionnary.java:57)
          at org.sonar.api.batch.BatchExtensionDictionnary.selectMavenPluginHandlers(BatchExtensionDictionnary.java:65)
          at org.sonar.batch.phases.MavenPluginsConfigurator.execute(MavenPluginsConfigurator.java:49)
          at org.sonar.batch.phases.Phases.execute(Phases.java:86)
          at org.sonar.batch.bootstrap.ProjectModule.doStart(ProjectModule.java:129)
          at org.sonar.batch.bootstrap.Module.start(Module.java:68)
          at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:147)
          at org.sonar.batch.bootstrap.BatchModule.doStart(BatchModule.java:136)
          at org.sonar.batch.bootstrap.Module.start(Module.java:68)
          at org.sonar.batch.bootstrap.BootstrapModule.doStart(BootstrapModule.java:83)
          at org.sonar.batch.bootstrap.Module.start(Module.java:68)
          at org.sonar.batch.Batch.execute(Batch.java:106)
          at org.sonar.runner.internal.batch.Launcher.executeBatch(Launcher.java:69)
          at org.sonar.runner.internal.batch.Launcher.execute(Launcher.java:61)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:601)
          at org.sonar.runner.Runner.delegateExecution(Runner.java:285)
          ... 3 more
      

        Activity

        Lars K. W. Gohlke added a comment -

        commit 988561286f5306871de8f4457d17aa2147d1a603

        Alpesh added a comment -

        I am having maven project and still same issue. What could be the reason. When sonar:sonar is executed, there is no issue and getting report on sonar but issue is only while running local sonar analysis with sonar eclipse plugin. Any idea?

        Lars K. W. Gohlke added a comment -

        If u dont have the same issue please create a new issue and plz give a at least some details of which version of what u use (eclipse, jdk, maven, plugin-version, sonar, installed plugin of sonar etc.)

        thx.

        Alpesh added a comment -

        Ok fine. I created SONARPLUGINS-2783


          People

          • Assignee:
            Lars Gohlke
            Reporter:
            Lars K. W. Gohlke
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: