SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-2380

Ensure that violations imported from Toad are not logged with a line <= 0.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: TOAD-1.0
    • Component/s: Toad
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The following warning is visible in some logs:

      12:36:45.621 WARN org.sonar.INFO- line must not be less than 1 - in future versions this will cause IllegalArgumentExceptionTotal time: 17:35.921s
      

      For file level violations, the setLine() method should not be called at all.

        Activity

        Dinesh Bolkensteyn added a comment -

        I managed to reproduce this with the rule: PLSQL - Avoid coding program units too long (Toad: 6802)

        Fabrice Bellingard added a comment -

        Could not reproduce the original problem.

        Dinesh Bolkensteyn added a comment -

        Ok so we're done


          People

          • Assignee:
            Dinesh Bolkensteyn
            Reporter:
            Eric Hartmann
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: