SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-2155

Only the first path of the 'binaries' property is taken into account by FindBugs

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: ANT-TASK-1.4
    • Fix Version/s: ANT-TASK-2.1
    • Component/s: Ant Task
    • Labels:
      None
    • Number of attachments :
      1

      Description

      build.xml:

      ...
      <property name="sonar.binaries" value="C:/tools/sources/sonar-ex2/bin/server,C:/tools/sources/sonar-ex2/bin/client" />
      ...
      

      findbugs-result.xml:

      ...
      <Project>
          <Jar>C:\tools\sources\sonar-ex2\bin\server</Jar>
          <AuxClasspathEntry>C:\tools\sources\sonar-ex2\bin\client</AuxClasspathEntry>
      ...
      

      Should be:

      ...
      <Project>
          <Jar>C:\tools\sources\sonar-ex2\bin\server</Jar>
          <Jar>C:\tools\sources\sonar-ex2\bin\client</Jar>
      ...
      

      See http://sonar.15.n6.nabble.com/sonar-findbugs-and-ant-task-td5001561.html

        Issue Links

          Activity

          Fabrice Bellingard added a comment -

          The problem is on Sonar side, and this problem probably also affects the Sonar Runner.

          Florent Viguier added a comment -

          This issue is blocking for my company's project to use SONAR for Java code quality assessment.
          Please keep us informed when some progress is made in fixing it.

          Fabrice Bellingard added a comment -

          SONARPLUGINS-2818 should fix this.

          Julien HENRY added a comment -

          Should be fixed when using at least Sonar 3.5

          Fabrice Bellingard added a comment -

          Tested!

          Julien HENRY added a comment -

          No need for ITs


            People

            • Assignee:
              Julien HENRY
              Reporter:
              David Racodon
            • Votes:
              3 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: