SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-1787

Sonargraph Threshold Violation of Package Level Metrik (e.g. max number of Types) is not shown

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: SONARGRAPH-3.0.3
    • Fix Version/s: SONARGRAPH-3.0.4
    • Component/s: Sonargraph
    • Labels:
      None
    • Number of attachments :
      0

      Activity

      Ingmar Kellner added a comment -

      Sonargraph treats packages in a different way that is not compatible with Sonar:
      Packages with the same name contained in different root paths are "merged". Thus, there is no way to pin a threshold violations for package level metrics (i.e. number of types) to a specific package in a maven module.

      This is the reason, why the drill down for threshold violations does not list these kinds of metrics.


        People

        • Assignee:
          Ingmar Kellner
          Reporter:
          Ingmar Kellner
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: