Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: MOTIONCHART-1.4
    • Component/s: Motion Chart
    • Labels:
      None
    • Number of attachments :
      0

      Description

      That would allow to add motion charts to both global and project dashboards.

      Moreover this should now be the responsibility of the widget to decide/configure :

      • which metric should be used on each axe
      • the size of the motion chart
      • which level should be displayed (in case of a project dashboard => display the project or its components?)

        Issue Links

          Activity

          Freddy Mallet added a comment - - edited

          @Fabrice, here are several improvements :

          • Rename the "Global Motion Chart" into "Filter Motion Chart"
          • Always display a title for the "Filter Motion Chart" and this title should always contain the filter which is used to determine the resources to be displayed
          • The way to display title in project dashboard is different than the one used in the TimeLine and History Table widgets so I guess we should decide what is the official pattern
          • It not possible to select a filter which returns some views or developers. In that case, we get a rails error : "undefined method `created_at' for nil:NilClass"
          • When we select a filter which returns a lot of files, only a short part of them seem to be displayed.
          • The components checkbox should be available only in edit mode and should be selected by default (as this is currently the case). We could even imagine to fully remove this property (as displaying only the current resource doesn't seem to be very valuable) and to replace it by another "display source files" property to display either : the measures at file level or the measures at sub-components level
          • The default height should be 400
          Fabrice Bellingard added a comment -

          All fixed (though I could not reproduce the problem with views or developers, this works perfectly on my side on Postgres & H2).

          Freddy Mallet added a comment -

          Perfect Fabrice ! I've done several tests and I guess the most useful metrics by default should be :

          • metric-y : coverage (no change)
          • metric-x : lines of code (instead of RCI)
          • metric-size : violations
          • metric-color : duplicated lines

          Could you also slightly update the description of the Filter Motion Chart :

          Displays a motion chart showing the evolution over time of a set of metrics on the result of specified filter

          Freddy Mallet added a comment -

          I also know when the rails error : "undefined method `created_at' for nil:NilClass" is raised : this is when a filter doesn't return any result. So this is a very minor issue.

          Fabrice Bellingard added a comment -

          Feedback applied + display "No data" if a filter returns no resource.

          Freddy Mallet added a comment -

          Manually tested !


            People

            • Assignee:
              Fabrice Bellingard
              Reporter:
              Simon Brandhof
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: