SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-1664

"Include number of violations per rule" shows all zeros

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: CSV-EXPORT-1.2
    • Fix Version/s: CSV-EXPORT-1.3
    • Labels:
      None
    • Environment:
      Sonar 2.13.1 using Derby DB on Windows Server 2008 R2 SP1 with plugins:
      - ABAP 1.1
      - C# Core 1.2
      - C# FxCop 1.2
      - C# Squid 1.0
      - CSV Export 1.2
      - PL/SQL 1.13
      - Switch Off Violations 1.0
      - Views 1.6.2
    • Number of attachments :
      0

      Description

      If "Include number of violations per rule" is checked when exporting violations to CSV, the number of violations for each rule is zero in the resulting CSV file, even for objects whose violation counts are not zero. Occurs with Java projects, not yet tested with other languages.

        Activity

        Ronald Jenkins Jr added a comment -

        I've confirmed that this issue occurs with an otherwise vanilla installation of Sonar 2.13 and 2.13.1. It is not a conflict with other Sonar plugins.

        Neway Liu added a comment -

        I met the same issue with Sonar 3.0

        Freddy Mallet added a comment -

        Indeed guys, I do confirm the issue and we'll fix it in the next 1.3 version of the plugin.

        Neway Liu added a comment -

        Great, currently can only use sonar 2.1 to get it works.

        Fabrice Bellingard added a comment -

        Fixed.
        The problem occured because Sonar 2.13 splitted the "violations" metric down into 5 new metrics ("info_violations", "minor_violations", ...etc).

        Therefore, version 1.3 of the plugin is compatible with Sonar 2.13+ only.

        Freddy Mallet added a comment -

        Manually tested !


          People

          • Assignee:
            Fabrice Bellingard
            Reporter:
            Ronald Jenkins Jr
          • Votes:
            3 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: