SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-1559

Cross project duplication detection for Flex

    Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: FLEX-1.0
    • Component/s: Flex
    • Labels:
      None
    • Number of attachments :
      0

      Issue Links

        Activity

        Evgeny Mandrikov made changes -
        Field Original Value New Value
        Link This issue depends upon SONAR-2843 [ SONAR-2843 ]
        Freddy Mallet made changes -
        Fix Version/s FLEX-0.5 [ 18265 ]
        Freddy Mallet made changes -
        Link This issue depends upon SONAR-3181 [ SONAR-3181 ]
        Evgeny Mandrikov made changes -
        Link This issue depends upon SONAR-3181 [ SONAR-3181 ]
        Evgeny Mandrikov made changes -
        Fix Version/s FLEX-1.0 [ 18265 ]
        Fabrice Bellingard made changes -
        Assignee Fabrice Bellingard [ fabemn ]
        Fix Version/s FLEX-1.0 [ 18265 ]
        Hide
        Fabrice Bellingard added a comment -

        Done on r5127.

        Please note that:

        • this will work starting with Sonar 2.14
        • some code has been duplicated from Sonar (like for PHP) to allow this. This code should be removed when the API in Sonar is available (see attached issue SONAR-2843).
        Show
        Fabrice Bellingard added a comment - Done on r5127. Please note that: this will work starting with Sonar 2.14 some code has been duplicated from Sonar (like for PHP) to allow this. This code should be removed when the API in Sonar is available (see attached issue SONAR-2843 ).
        Fabrice Bellingard made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hide
        Evgeny Mandrikov added a comment -

        Fabrice, I would prefer to leave this ticket open and resolve only SONARPLUGINS-424. In order to have list of tickets linked with SONAR-2843 which mentions all plugins whither require new API.

        Show
        Evgeny Mandrikov added a comment - Fabrice, I would prefer to leave this ticket open and resolve only SONARPLUGINS-424 . In order to have list of tickets linked with SONAR-2843 which mentions all plugins whither require new API.
        Freddy Mallet made changes -
        Assignee Fabrice Bellingard [ fabemn ] Freddy Mallet [ freddy.mallet ]
        Hide
        Freddy Mallet added a comment -

        Manually tested

        Show
        Freddy Mallet added a comment - Manually tested
        Freddy Mallet made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Assignee Freddy Mallet [ freddy.mallet ] Fabrice Bellingard [ fabemn ]

          People

          • Assignee:
            Fabrice Bellingard
            Reporter:
            Evgeny Mandrikov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: