SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-1552

Version is missing in component timeline for Ant modules

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: ANT-TASK-1.2
    • Fix Version/s: ANT-TASK-2.0
    • Component/s: Ant Task
    • Labels:
      None
    • Environment:
      Client: Windows 7 x64, JDK 1.6.0_29, Ant 1.8.1
      Server: Linux, Sonar 2.11
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      When analyzing a multi-modules Ant project, the version as defined with attribute version in the sonar task is correctly setup for the parent projet, it can be seen in the timeline view. However for the components (the Ant modules), the version is missing. So in the end with a timeline for each component with dates but no version. Maven projects do have this version for component, so I think that the current behavior is not correct.

      To reproduce the bug, simply analyze the multi module example project, go to timeline of Module1, there is no version.

      Attached is a simple patch against trunk revision 4600 that does seems to fix this. However I don't know if this is the right way to do it.

        Activity

        Frédéric Chopard added a comment -

        I have a question regarding fixing our existing data. We already have a lot of analysis performed on our system and they all misses the version in the components. However as the data is here in the database for each component and we have the version number on the parent project, is there a way to update the database using some sql query to add the version in the components ?

        Freddy Mallet added a comment -

        Hi Frédéric, in fact with Sonar 2.12, the History service on each project can be used to update/delete/define an event on a root project and this event is automatically propagated to sub-modules.

        Fabrice Bellingard added a comment -

        Frédéric, do you still get this bug with the latest version of the Ant Task (1.4)? I cannot reproduce the issue.

        Frédéric Chopard added a comment -

        Hi Fabrice, it will be difficult for me to test this behavior again as I'm not working on the project which was using this Ant task. I will try to get in touch with someone who's using it, but it will take some time before I can get back to you.

        Fabrice Bellingard added a comment -

        No problem Frédéric, there's no hurry as I could not reproduce the issue.
        Thanks

        Freddy Mallet added a comment -

        Manually tested !


          People

          • Assignee:
            Fabrice Bellingard
            Reporter:
            Frédéric Chopard
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: