SonarQube Plugins
  1. SonarQube Plugins
  2. SONARPLUGINS-1100

The plugin is not compatible with 1.2.5 mantis version

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: MANTIS-0.1
    • Fix Version/s: MANTIS-0.2
    • Component/s: Mantis
    • Labels:
      None
    • Environment:
      Windows XP 2, Sonar 2.7, Mantis 1.2.5. Mysql 5.0, Intel dual core processor
    • Number of attachments :
      1

      Description

      Hi,

      I have been trying to integrate sonar with mantis for 1 week, but i am not able to get mantis bug report on sonar dashboard, when i run build using hudson or command line, I get following error:

      [INFO]  Retrieve changelog from revision 22 done: 532 ms [INFO]  Retrieve files SCM info... 
      [INFO]  Retrieve files SCM info done: 125 ms [INFO]  Sensor ScmActivitySensor done: 2625 ms [INFO]  Sensor MantisSensor... 
      [WARN]  Unable to find required classes (javax.activation.DataHandler and javax.mail.internet.MimeMultipart). Attachment support is disabled. 
      [ERROR]  Exception: 
      org.xml.sax.SAXException: Invalid element in biz.futureware.mantis.rpc.soap.client.FilterData - url 
              at org.apache.axis.encoding.ser.BeanDeserializer.onStartChild(BeanDeserializer.java:258) [axis-1.3.jar:na] 
              at org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1035) [axis-1.3.jar:na] 
              at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165) [axis-1.3.jar:na] 
              at org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141) [axis-1.3.jar:na] 
              at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:236) [axis-1.3.jar:na] 
              at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384) [axis-1.3.jar:na] 
              at org.apache.axis.client.Call.invoke(Call.java:2467) [axis-1.3.jar:na] 
              at org.apache.axis.client.Call.invoke(Call.java:2366) [axis-1.3.jar:na] 
              at org.apache.axis.client.Call.invoke(Call.java:1812) [axis-1.3.jar:na] 
              at biz.futureware.mantis.rpc.soap.client.MantisConnectBindingStub.mc_filter_get(MantisConnectBindingStub.java:2837) [sonar-mantis-plugin-0.1.jar:na] 
              at org.sonar.plugins.mantis.soap.MantisSoapService.getFilters(MantisSoapService.java:84) [sonar-mantis-plugin-0.1.jar:na] 
              at org.sonar.plugins.mantis.MantisSensor.analyze(MantisSensor.java:112) [sonar-mantis-plugin-0.1.jar:na] 
              at org.sonar.plugins.mantis.MantisSensor.analyse(MantisSensor.java:94) [sonar-mantis-plugin-0.1.jar:na] 
              at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:59) [sonar-batch-2.7.jar:na] 
              at org.sonar.batch.phases.Phases.execute(Phases.java:75) [sonar-batch-2.7.jar:na] 
              at org.sonar.batch.ProjectBatch.execute(ProjectBatch.java:55) [sonar-batch-2.7.jar:na] 
              at org.sonar.batch.Batch.analyzeModule(Batch.java:158) [sonar-batch-2.7.jar:na] 
              at org.sonar.batch.Batch.analyzeModules(Batch.java:76) [sonar-batch-2.7.jar:na] 
              at org.sonar.batch.Batch.execute(Batch.java:62) [sonar-batch-2.7.jar:na] 
              at org.sonar.maven3.SonarMojo.executeBatch(SonarMojo.java:144) [sonar-maven3-plugin-2.7.jar:na] 
              at org.sonar.maven3.SonarMojo.execute(SonarMojo.java:135) [sonar-maven3-plugin-2.7.jar:na] 
              at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:113) [sonar-maven-plugin-2.0-beta-2.jar:na] 
              at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65) [sonar-maven-plugin-2.0-beta-2.jar:na] 
              at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:90) [sonar-maven-plugin-2.0-beta-2.jar:na] 
              at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156) [maven-core-3.0.3.jar:3.0.3] 
              at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537) [maven-embedder-3.0.3.jar:3.0.3] 
              at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196) [maven-embedder-3.0.3.jar:3.0.3] 
              at org.apache.maven.cli.MavenCli.main(MavenCli.java:141) [maven-embedder-3.0.3.jar:3.0.3] 
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [na:1.6.0_11] 
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) [na:1.6.0_11] 
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) [na:1.6.0_11] 
              at java.lang.reflect.Method.invoke(Method.java:597) [na:1.6.0_11] 
              at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290) [plexus-classworlds-2.4.jar:na] 
              at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230) [plexus-classworlds-2.4.jar:na] 
              at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409) [plexus-classworlds-2.4.jar:na] 
              at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352) [plexus-classworlds-2.4.jar:na] [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1:12.295s
      [INFO] Finished at: Tue Apr 19 17:17:37 GMT+05:30 2011 [INFO] Final Memory: 16M/254M [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.codehaus.mojo:sonar-maven-plugin:2.0-beta-2:sonar (default-cli) on project CMAgent: Can not execute Sonar: Error accessing Mantis web service, please verify the parameters: ; nested exception is: 
      [ERROR] org.xml.sax.SAXException: Invalid element in biz.futureware.mantis.rpc.soap.client.FilterData - url [ERROR] -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:sonar-maven-plugin:2.0-beta-2:sonar (default-cli) on project CMAgent: Can not execute Sonar 
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217) 
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) 
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) 
              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84) 
              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59) 
              at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183) 
              at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161) 
              at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319) 
              at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156) 
              at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537) 
              at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196) 
              at org.apache.maven.cli.MavenCli.main(MavenCli.java:141) 
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) 
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) 
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) 
              at java.lang.reflect.Method.invoke(Method.java:597) 
              at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290) 
              at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230) 
              at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409) 
              at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Can not execute Sonar 
              at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:118) 
              at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65) 
              at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:90) 
              at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101) 
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209) 
              ... 19 more
      Caused by: org.sonar.api.utils.SonarException: Error accessing Mantis web service, please verify the parameters 
              at org.sonar.plugins.mantis.MantisSensor.analyse(MantisSensor.java:97) 
              at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:59) 
              at org.sonar.batch.phases.Phases.execute(Phases.java:75) 
              at org.sonar.batch.ProjectBatch.execute(ProjectBatch.java:55) 
              at org.sonar.batch.Batch.analyzeModule(Batch.java:158) 
              at org.sonar.batch.Batch.analyzeModules(Batch.java:76) 
              at org.sonar.batch.Batch.execute(Batch.java:62) 
              at org.sonar.maven3.SonarMojo.executeBatch(SonarMojo.java:144) 
              at org.sonar.maven3.SonarMojo.execute(SonarMojo.java:135) 
              at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:113) 
              ... 23 more
      Caused by: org.xml.sax.SAXException: Invalid element in biz.futureware.mantis.rpc.soap.client.FilterData - url 
              at org.apache.axis.AxisFault.makeFault(AxisFault.java:101) 
              at org.apache.axis.client.Call.invoke(Call.java:2470) 
              at org.apache.axis.client.Call.invoke(Call.java:2366) 
              at org.apache.axis.client.Call.invoke(Call.java:1812) 
              at biz.futureware.mantis.rpc.soap.client.MantisConnectBindingStub.mc_filter_get(MantisConnectBindingStub.java:2837) 
              at org.sonar.plugins.mantis.soap.MantisSoapService.getFilters(MantisSoapService.java:84) 
              at org.sonar.plugins.mantis.MantisSensor.analyze(MantisSensor.java:112) 
              at org.sonar.plugins.mantis.MantisSensor.analyse(MantisSensor.java:94) 
              ... 32 more
      Caused by: org.xml.sax.SAXException: Invalid element in biz.futureware.mantis.rpc.soap.client.FilterData - url 
              at org.apache.axis.encoding.ser.BeanDeserializer.onStartChild(BeanDeserializer.java:258) 
              at org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1035) 
              at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165) 
              at org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141) 
              at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:236) 
              at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384) 
              at org.apache.axis.client.Call.invoke(Call.java:2467) 
              ... 38 more
      [ERROR]
      [ERROR] Re-run Maven using the -X switch to enable full debug logging. 
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles: 
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
      

      It looks like, mantis filter issue, but i have tried in all way.
      If any one having idea or procedure about creation of filter in mantis, and integrate with sonar, please help me.. I am new to mantis, but i am using sonar since 1 year.

      Thanks in advance...

      1. MantisError.docx
        482 kB
        umashankar prasad

        Issue Links

          Activity

          Jérémie Lagarde added a comment -

          Can you use the -X like : mvn sonar:sonar -X

          Have you configured a filter name for the project?
          The connection (url/user/password) and the mantis project name seems right.

          umashankar prasad added a comment - - edited

          Hi,

          I have attached file with screen shot of used procedure to create filter in mantis and provide details to sonar.

          I have run command mvn sonar:sonar -X, output are following:

          [INFO] ------------------------------------------------------------------------
          [INFO] Building CMAgent1.0 1.1
          [INFO] ------------------------------------------------------------------------
          [INFO] 
          [INFO] --- sonar-maven-plugin:2.0-beta-2:sonar (default-cli) @ CMAgent ---
          [INFO] Sonar version: 2.7
          [INFO]  Database dialect class org.sonar.jpa.dialect.MySql
          [INFO]  Execution environment: Maven 3.0.3
          [INFO]  -------------  Analyzing CMAgent1.0
          [INFO]  Selected quality profile : [name=Sonar way with Findbugs,language=java]
          [INFO]  Compare to previous analysis  (2011-04-20)
          [INFO]  Compare over 5 days (2011-04-15, analysis of 2011-04-18 15:10:51.0)
          [INFO]  Compare over 30 days (2011-03-21, analysis of 2011-04-11 14:49:18.0)
          [INFO]  Configure maven plugins...
          [INFO]  Initializer MavenInitializer...
          [INFO]  Java source version: 1.6
          [INFO]  Java target version: 1.6
          [INFO]  Source encoding: null
          [INFO]  Initializer MavenInitializer done: 16 ms
          [INFO]  Execute maven plugin cobertura-maven-plugin...
          [INFO]  Execute org.codehaus.mojo:cobertura-maven-plugin:2.4:cobertura...
          [INFO]                                                                         
          [INFO] ------------------------------------------------------------------------
          [INFO] Building CMAgent1.0 1.1
          [INFO] ------------------------------------------------------------------------
          [INFO] 
          [INFO] >>> cobertura-maven-plugin:2.4:cobertura (default-cli) @ CMAgent >>>
          [INFO] 
          [INFO] --- maven-resources-plugin:2.4.3:resources (default-resources) @ CMAgent ---
          [WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!
          [INFO] Copying 4 resources
          [INFO] 
          [INFO] --- maven-compiler-plugin:2.3.2:compile (default-compile) @ CMAgent ---
          [INFO] Nothing to compile - all classes are up to date
          [INFO] 
          [INFO] --- cobertura-maven-plugin:2.4:instrument (default-cli) @ CMAgent ---
          [INFO] Cobertura 1.9.4.1 - GNU GPL License (NO WARRANTY) - See COPYRIGHT file
          Cobertura: Loaded information on 14 classes.
          Instrumenting 14 files to E:\CMAgnet\target\generated-classes\cobertura
          [cobertura] WARN  [main] net.sourceforge.cobertura.instrument.ClassInstrumenter - No line number information found for class cmagentsrc.SSHClient$1.  Perhaps you need to compile with debug=true?
          Cobertura: Saved information on 14 classes.
          Instrument time: 453ms
          
          [INFO] Instrumentation was successful.
          [INFO] 
          [INFO] --- maven-resources-plugin:2.4.3:testResources (default-testResources) @ CMAgent ---
          [WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!
          [INFO] Copying 0 resource
          [INFO] 
          [INFO] --- maven-compiler-plugin:2.3.2:testCompile (default-testCompile) @ CMAgent ---
          [INFO] Nothing to compile - all classes are up to date
          [INFO] 
          [INFO] --- maven-surefire-plugin:2.7.2:test (default-test) @ CMAgent ---
          [INFO] Surefire report directory: E:\CMAgnet\target\surefire-reports
          
          -------------------------------------------------------
           T E S T S
          -------------------------------------------------------
          There are no tests to run.
          
          Results :
          
          Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
          
          [INFO] 
          [INFO] <<< cobertura-maven-plugin:2.4:cobertura (default-cli) @ CMAgent <<<
          [INFO] 
          [INFO] --- cobertura-maven-plugin:2.4:cobertura (default-cli) @ CMAgent ---
          [INFO] Cobertura 1.9.4.1 - GNU GPL License (NO WARRANTY) - See COPYRIGHT file
          Cobertura: Loaded information on 14 classes.
          Report time: 515ms
          
          [INFO] Cobertura Report generation was successful.
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESS
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 20.516s
          [INFO] Finished at: Wed Apr 20 14:29:01 GMT+05:30 2011
          [INFO] Final Memory: 14M/254M
          [INFO] ------------------------------------------------------------------------
          [INFO]  Execute org.codehaus.mojo:cobertura-maven-plugin:2.4:cobertura done: 3807 ms
          [INFO]  Execute maven plugin cobertura-maven-plugin done: 3807 ms
          [INFO]  Initializer CoberturaMavenInitializer...
          [INFO]  Initializer CoberturaMavenInitializer done: 0 ms
          [INFO]  Sensor AsynchronousMeasuresSensor...
          [INFO]  Sensor AsynchronousMeasuresSensor done: 140 ms
          [INFO]  Sensor SquidSensor...
          [INFO]  Java AST scan...
          [INFO]  Java AST scan done: 624 ms
          [INFO]  Java bytecode scan...
          [INFO]  Java bytecode scan done: 219 ms
          [INFO]  Java Squid scan...
          [INFO]  Java Squid scan done: 0 ms
          [INFO]  Squid extraction...
          [INFO]  Package design analysis...
          [INFO]  Package design analysis done: 16 ms
          [INFO]  Squid extraction done: 639 ms
          [INFO]  Sensor SquidSensor done: 1529 ms
          [INFO]  Sensor JavaSourceImporter...
          [INFO]  Sensor JavaSourceImporter done: 406 ms
          [INFO]  Sensor FindbugsSensor...
          [INFO]  Execute Findbugs 1.3.9...
          [INFO]  Found findbugs plugin: file:/C:/DOCUME~1/eeglab/LOCALS~1/Temp/sonar-batch53354828774411283331994211276770/findbugs/findbugs-1.3.9.jar
          [INFO]  Loaded plugin edu.umd.cs.findbugs.plugins.core
          [INFO]  Findbugs output report: E:\CMAgnet\target\sonar\findbugs-result.xml
          [INFO]  Execute Findbugs 1.3.9 done: 10984 ms
          [INFO]  Sensor FindbugsSensor done: 11280 ms
          [INFO]  Sensor SurefireSensor...
          [INFO]  parsing E:\CMAgnet\target\surefire-reports
          [INFO]  Sensor SurefireSensor done: 16 ms
          [INFO]  Sensor CpdSensor...
          [INFO]  Sensor CpdSensor done: 140 ms
          [INFO]  Sensor CheckstyleSensor...
          [INFO]  Execute Checkstyle 5.1...
          [INFO]  Checkstyle configuration: E:\CMAgnet\target\sonar\checkstyle.xml
          [INFO]  Execute Checkstyle 5.1 done: 2262 ms
          [INFO]  Sensor CheckstyleSensor done: 2262 ms
          [INFO]  Sensor PmdSensor...
          [INFO]  Execute PMD 4.2.5...
          [INFO]  Java version: 1.6
          [INFO]  PMD configuration: E:\CMAgnet\target\sonar\pmd.xml
          [INFO]  PMD output report: E:\CMAgnet\target\sonar\pmd-result.xml
          [INFO]  Execute PMD 4.2.5 done: 3230 ms
          [INFO]  Sensor PmdSensor done: 4244 ms
          [INFO]  Sensor ProfileSensor...
          [INFO]  Sensor ProfileSensor done: 0 ms
          [INFO]  Sensor ProjectLinksSensor...
          [INFO]  Sensor ProjectLinksSensor done: 16 ms
          [INFO]  Sensor VersionEventsSensor...
          [INFO]  Sensor VersionEventsSensor done: 31 ms
          [INFO]  Sensor CoberturaSensor...
          [INFO]  parsing E:\CMAgnet\target\site\cobertura\coverage.xml
          [INFO]  Sensor CoberturaSensor done: 140 ms
          [INFO]  Sensor Maven dependencies...
          [INFO]  Sensor Maven dependencies done: 1295 ms
          [INFO]  Sensor org.sonar.plugins.buildstability.BuildStabilitySensor@95a1b6...
          [INFO]  CI URL: Hudson:http://localhost:8080/jenkins/job/CMAgentNew/
          [INFO]  Retrieved 24 builds since Mon Mar 21 14:29:23 GMT+05:30 2011
          [INFO]  Sensor org.sonar.plugins.buildstability.BuildStabilitySensor@95a1b6 done: 718 ms
          [INFO]  Sensor ScmActivitySensor...
          [INFO]  Check for local modifications...
          [INFO]  	Executing: cmd.exe /X /C "svn --username svnadmin --password ***** --no-auth-cache --non-interactive --trust-server-cert status"
          [INFO]  	Working directory: E:\CMAgnet\src\main\java
          [INFO]  	Executing: cmd.exe /X /C "svn --username svnadmin --password ***** --no-auth-cache --non-interactive --trust-server-cert status"
          [INFO]  	Working directory: E:\CMAgnet\src\test\java
          [INFO]  Check for local modifications done: 406 ms
          [INFO]  Retrieve changelog from revision 22...
          [INFO]  	Executing: cmd.exe /X /C "svn --username svnadmin --password ***** --no-auth-cache --non-interactive --trust-server-cert log -v -r 22:BASE"
          [INFO]  	Working directory: E:\CMAgnet
          [INFO]  Retrieve changelog from revision 22 done: 156 ms
          [INFO]  Retrieve files SCM info...
          [INFO]  Retrieve files SCM info done: 110 ms
          [INFO]  Sensor ScmActivitySensor done: 749 ms
          [INFO]  Sensor MantisSensor...
          [WARN]  Unable to find required classes (javax.activation.DataHandler and javax.mail.internet.MimeMultipart). Attachment support is disabled.
          [ERROR]  Exception:
          org.xml.sax.SAXException: Invalid element in biz.futureware.mantis.rpc.soap.client.FilterData - url
          	at org.apache.axis.encoding.ser.BeanDeserializer.onStartChild(BeanDeserializer.java:258) [axis-1.3.jar:na]
          	at org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1035) [axis-1.3.jar:na]
          	at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165) [axis-1.3.jar:na]
          	at org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141) [axis-1.3.jar:na]
          	at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:236) [axis-1.3.jar:na]
          	at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384) [axis-1.3.jar:na]
          	at org.apache.axis.client.Call.invoke(Call.java:2467) [axis-1.3.jar:na]
          	at org.apache.axis.client.Call.invoke(Call.java:2366) [axis-1.3.jar:na]
          	at org.apache.axis.client.Call.invoke(Call.java:1812) [axis-1.3.jar:na]
          	at biz.futureware.mantis.rpc.soap.client.MantisConnectBindingStub.mc_filter_get(MantisConnectBindingStub.java:2837) [sonar-mantis-plugin-0.1.jar:na]
          	at org.sonar.plugins.mantis.soap.MantisSoapService.getFilters(MantisSoapService.java:84) [sonar-mantis-plugin-0.1.jar:na]
          	at org.sonar.plugins.mantis.MantisSensor.analyze(MantisSensor.java:112) [sonar-mantis-plugin-0.1.jar:na]
          	at org.sonar.plugins.mantis.MantisSensor.analyse(MantisSensor.java:94) [sonar-mantis-plugin-0.1.jar:na]
          	at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:59) [sonar-batch-2.7.jar:na]
          	at org.sonar.batch.phases.Phases.execute(Phases.java:75) [sonar-batch-2.7.jar:na]
          	at org.sonar.batch.ProjectBatch.execute(ProjectBatch.java:55) [sonar-batch-2.7.jar:na]
          	at org.sonar.batch.Batch.analyzeModule(Batch.java:158) [sonar-batch-2.7.jar:na]
          	at org.sonar.batch.Batch.analyzeModules(Batch.java:76) [sonar-batch-2.7.jar:na]
          	at org.sonar.batch.Batch.execute(Batch.java:62) [sonar-batch-2.7.jar:na]
          	at org.sonar.maven3.SonarMojo.executeBatch(SonarMojo.java:144) [sonar-maven3-plugin-2.7.jar:na]
          	at org.sonar.maven3.SonarMojo.execute(SonarMojo.java:135) [sonar-maven3-plugin-2.7.jar:na]
          	at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:113) [sonar-maven-plugin-2.0-beta-2.jar:na]
          	at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65) [sonar-maven-plugin-2.0-beta-2.jar:na]
          	at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:90) [sonar-maven-plugin-2.0-beta-2.jar:na]
          	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156) [maven-core-3.0.3.jar:3.0.3]
          	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537) [maven-embedder-3.0.3.jar:3.0.3]
          	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196) [maven-embedder-3.0.3.jar:3.0.3]
          	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141) [maven-embedder-3.0.3.jar:3.0.3]
          	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [na:1.6.0_11]
          	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) [na:1.6.0_11]
          	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) [na:1.6.0_11]
          	at java.lang.reflect.Method.invoke(Method.java:597) [na:1.6.0_11]
          	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290) [plexus-classworlds-2.4.jar:na]
          	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230) [plexus-classworlds-2.4.jar:na]
          	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409) [plexus-classworlds-2.4.jar:na]
          	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352) [plexus-classworlds-2.4.jar:na]
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD FAILURE
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 46.728s
          [INFO] Finished at: Wed Apr 20 14:29:27 GMT+05:30 2011
          [INFO] Final Memory: 23M/254M
          [INFO] ------------------------------------------------------------------------
          [ERROR] Failed to execute goal org.codehaus.mojo:sonar-maven-plugin:2.0-beta-2:sonar (default-cli) on project CMAgent: Can not execute Sonar: Error accessing Mantis web service, please verify the parameters: ; nested exception is:
          [ERROR] org.xml.sax.SAXException: Invalid element in biz.futureware.mantis.rpc.soap.client.FilterData - url
          [ERROR] -> [Help 1]
          [ERROR] 
          [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
          [ERROR] Re-run Maven using the -X switch to enable full debug logging.
          [ERROR] 
          [ERROR] For more information about the errors and possible solutions, please read the following articles:
          [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
          
          Jérémie Lagarde added a comment -

          This seems to come from a change in the latest SOAP service version (1.2.5):
          http://www.mantisbt.org/bugs/view.php?id=12765
          http://git.mantisbt.org/?p=mantisbt.git;a=commitdiff;h=45ef6c7091c4c99e7f020dc3d29707cda61709bc

          I try to resolve the problem as soon as possible.

          Regards,
          Jeremie.

          umashankar prasad added a comment -

          Which version of mantis shall i use to get into this?

          Jérémie Lagarde added a comment -
          umashankar prasad added a comment -

          Thanks alot for your quick response.. I have tried with version 0.2-SNAPSHOT plugin, and it works fine with mantis 1.2.5.

          But now we are planning to write a plugin for bugzilla, Could you please provide me some guidelines to develop.

          Thanks & Regards
          Umashankar Prasad

          Andreas Hahne added a comment -

          I recently witnessed exactly this error with Sonar 3.0.1, Mantis Plugin 0.3, and Mantis 1.2.10. Did this issue reappear?


            People

            • Assignee:
              Jérémie Lagarde
              Reporter:
              umashankar prasad
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: