SonarQube PHP
  1. SonarQube PHP
  2. SONARPHP-62

sonar.phpPmd.argumentLine argument not readable by phpmd

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 1.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      linux-x86, php 5.3
    • Number of attachments :
      0

      Description

      PHPMD uses a specific format for switches, using two arguments like the following synopsys:

       <switch name> <switch value>
      

      The issue is that the actual executor send the argument "sonar.phpPmd.argumentLine" escaped as one argument:

        "<switch name> <switch value>"
      

      So, phpmd is not able to read this argument and just ignore it, which cause a wrong behavior.

        Issue Links

          Activity

          Fabrice Bellingard added a comment -

          Can you give me example of use cases where you need those switches please?

          Noel GUILBERT added a comment -

          Actually, I'm using it because the ignore argument is not well taken in account... So I can put whatever I want with this property.
          Btw, if you want to use others switches (or custom switches if you extend phpmd), you can't do it because of this bug.


            People

            • Assignee:
              Fabrice Bellingard
              Reporter:
              Anonymous
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: