SonarQube PHP
  1. SonarQube PHP
  2. SONARPHP-51

unable to change severity for rule ArrayDeclarationvaluenotaligned

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1
    • Fix Version/s: 1.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      Sonar 3.3.2 + MySQL on Windows 2008r2
    • Number of attachments :
      0

      Description

      Changing ArrayDeclarationvaluenotaligned severity is correctly impacted in profile description, profile history and is visible in database but the rule is still in "Major" in the dashboard. This problem is not reproductible with other rules.

        Activity

        Fabrice Bellingard added a comment -

        Tested!

        Julien HENRY added a comment -

        No need for IT

        Frédéric Souchon aka Fraifrai added a comment -

        The problem persisted so that we directly edited the database that solved the problem.

        We think the problem was induced by multiple entries with the same profile_id and rule_id which is a nonsense.


          People

          • Assignee:
            Julien HENRY
            Reporter:
            Anonymous
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: