SonarQube PHP
  1. SonarQube PHP
  2. SONARPHP-37

java launcher failed load php converage

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.1
    • Component/s: None
    • Labels:
      None
    • Environment:
    • Number of attachments :
      3

      Description

      I've got this error and I can't figure out what is the pb :

      16:23:05.417 INFO Parsing file: /var/lib/jenkins/jobs/Sonar_W/workspace/.sonar/target/logs/phpunit.coverage.xml
      Total time: 50.663s
      Final Memory: 7M/155M
      Exception in thread "main" org.sonar.batch.bootstrapper.BootstrapException: java.lang.NullPointerException
      at org.sonar.runner.Runner.delegateExecution(Runner.java:189)
      at org.sonar.runner.Runner.execute(Runner.java:78)
      at org.sonar.runner.Main.main(Main.java:61)
      Caused by: java.lang.NullPointerException
      at org.sonar.plugins.php.phpunit.PhpUnitCoverageResultParser.saveCoverageMeasure(PhpUnitCoverageResultParser.java:143)
      at org.sonar.plugins.php.phpunit.PhpUnitCoverageResultParser.parseFileNodes(PhpUnitCoverageResultParser.java:123)
      at org.sonar.plugins.php.phpunit.PhpUnitCoverageResultParser.parseFile(PhpUnitCoverageResultParser.java:107)
      at org.sonar.plugins.php.phpunit.PhpUnitCoverageResultParser.parse(PhpUnitCoverageResultParser.java:91)
      at org.sonar.plugins.php.phpunit.PhpUnitSensor.analyse(PhpUnitSensor.java:74)
      at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:64)
      at org.sonar.batch.phases.Phases.execute(Phases.java:93)
      at org.sonar.batch.bootstrap.ProjectModule.doStart(ProjectModule.java:143)
      at org.sonar.batch.bootstrap.Module.start(Module.java:83)
      at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:111)
      at org.sonar.batch.bootstrap.BatchModule.doStart(BatchModule.java:101)
      at org.sonar.batch.bootstrap.Module.start(Module.java:83)
      at org.sonar.batch.bootstrap.BootstrapModule.doStart(BootstrapModule.java:102)
      at org.sonar.batch.bootstrap.Module.start(Module.java:83)
      at org.sonar.batch.Batch.execute(Batch.java:100)
      at org.sonar.runner.Launcher.executeBatch(Launcher.java:65)
      at org.sonar.runner.Launcher.execute(Launcher.java:58)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:616)
      at org.sonar.runner.Runner.delegateExecution(Runner.java:186)

      1. log.txt
        9 kB
        François Schneider
      2. phpunit.coverage.xml
        242 kB
        François Schneider
      3. sonar-project.properties
        1 kB
        François Schneider

        Activity

        Freddy Mallet added a comment -

        Please François, don't create any JIRA issue before having first discussed this issue on the Sonar User mailing list. Some PHP source file don't have any coverage by line information, this seems to be the root cause of this issue.


          People

          • Assignee:
            Fabrice Bellingard
            Reporter:
            Anonymous
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: